aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-08-27 22:00:46 -0400
committerChen Qi <Qi.Chen@windriver.com>2014-09-03 15:05:43 +0800
commitb200b4ce97c513af94517d6f4f4ee8c1a7ef66a8 (patch)
treeff558f7ccc0d38e95750bc4adabd680bccefbfa3
parent6556be21016a2b135f4847ca060caa83dc850d29 (diff)
downloadopenembedded-core-contrib-b200b4ce97c513af94517d6f4f4ee8c1a7ef66a8.tar.gz
keymaps: mask keymap when necessary
When 'sysvinit' and 'systemd' are both in DISTRO_FEATURES, we need to prevent the init script from running via systemd. This is because that the functionality of the init script has implemented in systemd internally. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-bsp/keymaps/keymaps_1.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-bsp/keymaps/keymaps_1.0.bb b/meta/recipes-bsp/keymaps/keymaps_1.0.bb
index a3f2d89b26..925161b5d2 100644
--- a/meta/recipes-bsp/keymaps/keymaps_1.0.bb
+++ b/meta/recipes-bsp/keymaps/keymaps_1.0.bb
@@ -35,4 +35,14 @@ do_install () {
fi
}
+DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
+pkg_postinst_${PN} () {
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd sysvinit','true','false',d)}; then
+ if [ -n "$D" ]; then
+ OPTS="--root=$D"
+ fi
+ systemctl $OPTS mask keymap.service
+ fi
+}
+
ALLOW_EMPTY_${PN} = "1"