aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrice Coulon <fabrice@axis.com>2014-10-03 10:21:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-10 10:39:12 +0100
commitd425e005d274cac0ef7160f53c41bda175444f69 (patch)
treecdb3fb9b5fa2aebba4cfe3d37d966eae1ef23064
parentd7bb1d8b1a7cd11895037b7984b9aa916efa9733 (diff)
downloadopenembedded-core-contrib-d425e005d274cac0ef7160f53c41bda175444f69.tar.gz
curl: add PACKAGECONFIG option to use libssh2
The user can enable libssh2 via conf/local.conf or custom distro configuration, this will pull in libssh2, which is not used by default. For example, a curl_x.y.z.bbappend file containing the following line: PACKAGECONFIG += "libssh2" Signed-off-by: Fabrice Coulon <fabrice.coulon@axis.com> Signed-off-by: Olof Johansson <olof.johansson@axis.com>
-rw-r--r--meta/recipes-support/curl/curl_7.37.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/curl/curl_7.37.1.bb b/meta/recipes-support/curl/curl_7.37.1.bb
index e2852e39a5..39ded80190 100644
--- a/meta/recipes-support/curl/curl_7.37.1.bb
+++ b/meta/recipes-support/curl/curl_7.37.1.bb
@@ -28,9 +28,9 @@ PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openss
PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
+PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
-EXTRA_OECONF = "--without-libssh2 \
- --without-libidn \
+EXTRA_OECONF = "--without-libidn \
--enable-crypto-auth \
--disable-ldap \
--disable-ldaps \