aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShrikant Bobade <Shrikant_Bobade@mentor.com>2014-08-11 15:07:59 +0530
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 11:16:54 +0100
commit4e5f6f95e8e791c9cfc9e3bd91f1018d83ab252f (patch)
tree92669012d5f2bf85a01aada0fb66b15166657ebc
parent76a702f4cde7ca8dd2946633f489386e43b6be26 (diff)
downloadopenembedded-core-contrib-4e5f6f95e8e791c9cfc9e3bd91f1018d83ab252f.tar.gz
gnupg: Added PACKAGECONFIG[curl]
gnupg can be built with or without curl. This should be explicitly defined to avoid race between curl and gnupg. Signed-off-by: Mikhail Durnev <mikhail_durnev@mentor.com> Signed-off-by: Shrikant Bobade <Shrikant_Bobade@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gnupg/gnupg_1.4.7.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_1.4.7.bb b/meta/recipes-support/gnupg/gnupg_1.4.7.bb
index 031eaf3cab..ddcc2c24fe 100644
--- a/meta/recipes-support/gnupg/gnupg_1.4.7.bb
+++ b/meta/recipes-support/gnupg/gnupg_1.4.7.bb
@@ -95,3 +95,6 @@ FILES_gpgv = "${bindir}/gpgv"
# Exclude debug files from the main packages
FILES_${PN} = "${bindir}/* ${datadir}/${BPN} ${libexecdir}/${BPN}/*"
FILES_${PN}-dbg += "${libexecdir}/${BPN}/.debug"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[curl] = "--with-libcurl=${STAGING_LIBDIR},--without-libcurl,curl"