aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Herbrechtsmeier <stefan@herbrechtsmeier.net>2012-04-05 13:48:27 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-06 01:08:33 +0100
commit794225ed3b6fe7878595b7452259cc9bf1973213 (patch)
treef417a4e9ac348c361e515dd30ac9f8b3a4a7540e
parentbaa1323dfff35ccd5aebc036ca97925a1f1a604e (diff)
downloadopenembedded-core-contrib-794225ed3b6fe7878595b7452259cc9bf1973213.tar.gz
u-boot: add machine name to spl image name
Signed-off-by: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net>
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.03.bb2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.06.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index 700d5d39f4..0445c343d3 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -32,7 +32,7 @@ UBOOT_MAKE_TARGET ?= "all"
# deploy directory. For those versions they can set the following variables
# to allow packaging the SPL.
SPL_BINARY ?= ""
-SPL_IMAGE ?= "${SPL_BINARY}-${PV}-${PR}"
+SPL_IMAGE ?= "${SPL_BINARY}-${MACHINE}-${PV}-${PR}"
SPL_SYMLINK ?= "${SPL_BINARY}-${MACHINE}"
do_compile () {
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.03.bb b/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
index 1ebdbeabca..e99bc2cab4 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
@@ -17,7 +17,7 @@ FILESDIR = "${@os.path.dirname(d.getVar('FILE',1))}/u-boot-git/${MACHINE}"
SRCREV = "19b54a701811220221fc4d5089a2bb18892018ca"
PV = "v2011.03+git${SRCPV}"
-PR = "r5"
+PR = "r6"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
index 8ebdbff5ea..680401f45b 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
@@ -17,7 +17,7 @@ FILESDIR = "${@os.path.dirname(d.getVar('FILE',1))}/u-boot-git/${MACHINE}"
SRCREV = "b1af6f532e0d348b153d5c148369229d24af361a"
PV = "v2011.06+git${SRCPV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"