aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhong Hongbo <hongbo.zhong@windriver.com>2013-11-19 17:19:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-18 11:14:39 +0000
commit9976a860b495256d94ec44c5084b13f214351547 (patch)
tree8302f321d6853ef2dd7b8d8cd8cc44272df1327e
parentc55918d73318fb86af122529bf1034826268356b (diff)
downloadopenembedded-core-contrib-9976a860b495256d94ec44c5084b13f214351547.tar.gz
bluez4: use legacy pygobject instead of gobject-introspection
pygobject-3.0 use GObject from gi.repository instead of gobject modules. Since oe-core use pygobject-2.x, change all of "from gi.repository import GObject" to "import gobject" for bluez4. Signed-off-by: Zhong Hongbo <hongbo.zhong@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-connectivity/bluez/bluez4-4.101/use-legacy-pygobject-instead-ofgobject-introspection.patch27
-rw-r--r--meta/recipes-connectivity/bluez/bluez4_4.101.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4-4.101/use-legacy-pygobject-instead-ofgobject-introspection.patch b/meta/recipes-connectivity/bluez/bluez4-4.101/use-legacy-pygobject-instead-ofgobject-introspection.patch
new file mode 100644
index 0000000000..37037f52e3
--- /dev/null
+++ b/meta/recipes-connectivity/bluez/bluez4-4.101/use-legacy-pygobject-instead-ofgobject-introspection.patch
@@ -0,0 +1,27 @@
+Upstream-Status: Inappropriate
+
+use legacy pygobject instead of gobject-introspection
+
+Signed-off-by: Zhong Hongbo <hongbo.zhong@windriver.com>
+---
+diff -Nurd bluez-4.101.orig/test/simple-agent bluez-4.101/test/simple-agent
+--- bluez-4.101.orig/test/simple-agent 2013-11-13 17:14:08.138118159 +0800
++++ bluez-4.101/test/simple-agent 2013-11-13 17:14:29.034118107 +0800
+@@ -2,7 +2,7 @@
+
+ from __future__ import absolute_import, print_function, unicode_literals
+
+-from gi.repository import GObject
++import gobject
+
+ import sys
+ import dbus
+@@ -122,7 +122,7 @@
+ path = "/test/agent"
+ agent = Agent(bus, path)
+
+- mainloop = GObject.MainLoop()
++ mainloop = gobject.MainLoop()
+
+ if len(args) > 1:
+ if len(args) > 2:
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.101.bb b/meta/recipes-connectivity/bluez/bluez4_4.101.bb
index 7127619ddf..543f854095 100644
--- a/meta/recipes-connectivity/bluez/bluez4_4.101.bb
+++ b/meta/recipes-connectivity/bluez/bluez4_4.101.bb
@@ -8,6 +8,7 @@ SRC_URI += "file://bluetooth.conf \
file://obsolete_automake_macros.patch \
file://network-fix-network-Connect-method-parameters.patch \
file://install-test-script.patch \
+ file://use-legacy-pygobject-instead-ofgobject-introspection.patch \
"
SRC_URI[md5sum] = "fb42cb7038c380eb0e2fa208987c96ad"