aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-03-27 15:29:02 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-27 15:44:16 +0000
commitee587332f2ac9d88d4a300732645b0e2f793ce5f (patch)
tree83a608108be11b4569aa40fb3b1526fc497aff3b
parent393fe40c14e7adeadbccb72953027b63b6f8030c (diff)
downloadopenembedded-core-contrib-ee587332f2ac9d88d4a300732645b0e2f793ce5f.tar.gz
gummiboot: fix the installed but not shipped warning
Fix the warning: WARNING: QA Issue: gummiboot: Files/directories were installed but not shipped /usr/lib /usr/lib/gummiboot /usr/lib/gummiboot/gummibootx64.efi This is because it uses "/usr/lib" in gummibootlibdir, use ${libdir} to fix it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-bsp/gummiboot/gummiboot_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gummiboot/gummiboot_git.bb b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
index 52a692b469..80df2b6ae3 100644
--- a/meta/recipes-bsp/gummiboot/gummiboot_git.bb
+++ b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
@@ -26,6 +26,8 @@ EXTRA_OECONF = "--disable-manpages --with-efi-includedir=${STAGING_INCDIR} \
--with-efi-ldsdir=${STAGING_LIBDIR} \
--with-efi-libdir=${STAGING_LIBDIR}"
+EXTRA_OEMAKE += "gummibootlibdir=${libdir}/gummiboot"
+
do_deploy () {
install ${B}/gummiboot*.efi ${DEPLOYDIR}
}