aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-27 17:19:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-09 16:00:17 +0000
commit6feef44751d98c55a2764d70c26d170f90b73f9d (patch)
tree48147d02c95722e4e3500f846880cdde9fa2cdcf
parent3993378c9a8994688fda15a5cd05e04a435d2d54 (diff)
downloadopenembedded-core-contrib-6feef44751d98c55a2764d70c26d170f90b73f9d.tar.gz
glibc_2.21.bb: Fix condition to skip parsing the recipe for non-glibc libc
The condition should be uclibc 'or' musl then we know its not glibc right now it checks with 'and' operator, that condition will never be true Change-Id: Ifc48e81fd0b3c18d8e1ef76a18c216dc6acda092 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index 6e540462cb..693d937345 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -67,7 +67,7 @@ GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn
#
python __anonymous () {
import re
- notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) and (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
+ notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) or (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
if notglibc:
raise bb.parse.SkipPackage("incompatible with target %s" %
d.getVar('TARGET_OS', True))