summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-05-20 15:51:20 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-22 16:09:21 +0100
commit378608a99560c7720189ca6ba4158e10cbe42abf (patch)
tree986f57037ff0158a897fa080fb7003dbdc978e26
parent05bce1fda9b24f939d211516ad73984ad29ba4df (diff)
downloadopenembedded-core-contrib-378608a99560c7720189ca6ba4158e10cbe42abf.tar.gz
openembedded-core-contrib-378608a99560c7720189ca6ba4158e10cbe42abf.tar.bz2
openembedded-core-contrib-378608a99560c7720189ca6ba4158e10cbe42abf.zip
libsoup-2.4: provide PACKAGECONFIG for gssapi
Fixes this build error: | ../../libsoup-2.54.1/libsoup/soup-auth-negotiate.c:16:27: fatal error: gssapi/gssapi.h: No such file or directory | compilation terminated. | Makefile:1166: recipe for target 'libsoup_2_4_la-soup-auth-negotiate.lo' failed | make[3]: *** [libsoup_2_4_la-soup-auth-negotiate.lo] Error 1 Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb
index ad8202ce7f..f243cbc898 100644
--- a/meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.54.1.bb
@@ -21,6 +21,7 @@ inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspecti
# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
PACKAGECONFIG ??= ""
PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
+PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5"
EXTRA_OECONF = "--disable-vala"