summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-12-02 17:37:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-05 22:28:10 +0000
commitd37c2d428b09b9d0cbb875f083c6a1e9883a7fed (patch)
tree9f8f60f655b58eeb35af9bafdc082aa78c9fe682
parentaf002ebd984efa254fe168895430cdb5d4cf23f9 (diff)
downloadopenembedded-core-contrib-d37c2d428b09b9d0cbb875f083c6a1e9883a7fed.tar.gz
glibc-tests: correctly pull in the actual tests when installing -ptest package
The tests are packaged into the main glibc-tests package which is fine, but then glibc-tests-ptest package needs to depend on that. Which is what this commit addresses. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-core/glibc/glibc-tests_2.36.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/glibc/glibc-tests_2.36.bb b/meta/recipes-core/glibc/glibc-tests_2.36.bb
index c71c0831c6..bb6ef06162 100644
--- a/meta/recipes-core/glibc/glibc-tests_2.36.bb
+++ b/meta/recipes-core/glibc/glibc-tests_2.36.bb
@@ -16,7 +16,6 @@ python __anonymous() {
d.setVar("PACKAGES", "${PN} ${PN}-ptest")
d.setVar("PROVIDES", "${PN} ${PN}-ptest")
- d.setVar("RPROVIDES", "${PN} ${PN}-ptest")
bbclassextend = d.getVar("BBCLASSEXTEND").replace("nativesdk", "").strip()
d.setVar("BBCLASSEXTEND", bbclassextend)
@@ -29,6 +28,7 @@ python __anonymous() {
RPROVIDES:${PN} = "${PN}"
RRECOMMENDS:${PN} = ""
RDEPENDS:${PN} = " glibc sed"
+RDEPENDS:${PN}-ptest = "${PN}"
DEPENDS += "sed"
export oe_srcdir="${exec_prefix}/src/debug/glibc/${PV}/"