aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-18 11:15:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-18 16:47:59 +0100
commit112775995158cf6c504fd6beef345ee446f4f11d (patch)
treed9f4108a78ca4f09b256fa4475c8eb38030ccd54
parent0772ed9acf96c53b05e6ac19e1af78bbb1192a3b (diff)
downloadopenembedded-core-contrib-112775995158cf6c504fd6beef345ee446f4f11d.tar.gz
qemux86/gstreamer: Move kernel module recommendation to the machine configuration
If you try to build a system with multiple BSPs, one of which is qemux86 or qemux86-64, the gstreamer package will change. This will trigger anything using gstream to also be rebuilt. For a package based system, the PR values will also be incremented each time. The end result will be an ever growing set of PR values as well as being unable to tell which configured version of the multimedia components are really being deployed. These therefore belong in the machine configuration. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/machine/qemux86-64.conf2
-rw-r--r--meta/conf/machine/qemux86.conf2
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.2.bb2
3 files changed, 4 insertions, 2 deletions
diff --git a/meta/conf/machine/qemux86-64.conf b/meta/conf/machine/qemux86-64.conf
index fd1f4142e9..9966d1a04c 100644
--- a/meta/conf/machine/qemux86-64.conf
+++ b/meta/conf/machine/qemux86-64.conf
@@ -31,6 +31,8 @@ MACHINE_FEATURES += "x86 pci"
MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "v86d"
+MACHINE_EXTRA_RRECOMMENDS = "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
+
KERNEL_MODULE_AUTOLOAD += "uvesafb"
KERNEL_MODULE_PROBECONF += "uvesafb"
module_conf_uvesafb = "options uvesafb mode_option=${UVESA_MODE}"
diff --git a/meta/conf/machine/qemux86.conf b/meta/conf/machine/qemux86.conf
index efcebb2782..e78fb6e87b 100644
--- a/meta/conf/machine/qemux86.conf
+++ b/meta/conf/machine/qemux86.conf
@@ -30,6 +30,8 @@ MACHINE_FEATURES += "x86 pci"
MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "v86d"
+MACHINE_EXTRA_RRECOMMENDS = "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
+
KERNEL_MODULE_AUTOLOAD += "uvesafb"
KERNEL_MODULE_PROBECONF += "uvesafb"
module_conf_uvesafb = "options uvesafb mode_option=${UVESA_MODE}"
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.2.bb
index 7f291f6630..3a6e53de04 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.2.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.2.bb
@@ -55,8 +55,6 @@ FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
-RRECOMMENDS_${PN}_qemux86 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
-RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
RDEPENDS_${PN}-ptest += "make"
delete_pkg_m4_file() {