summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2019-01-29 15:57:13 -0800
committerArmin Kuster <akuster808@gmail.com>2019-04-22 06:03:34 -0600
commit34bf48af5d36549f75e1c00f0b3b049d968fb7af (patch)
tree43796260b872fcf3a890ce5e81edbb1560d70508
parent24d61bbc1e0acd380190f655a0d31a801c22cd2c (diff)
downloadopenembedded-core-contrib-34bf48af5d36549f75e1c00f0b3b049d968fb7af.tar.gz
openembedded-core-contrib-34bf48af5d36549f75e1c00f0b3b049d968fb7af.tar.bz2
openembedded-core-contrib-34bf48af5d36549f75e1c00f0b3b049d968fb7af.zip
manual qa/bsp-qemu: remove KVM enabled which is already done in selftest runqemu
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/lib/oeqa/manual/bsp-qemu.json30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta/lib/oeqa/manual/bsp-qemu.json b/meta/lib/oeqa/manual/bsp-qemu.json
index f680f64701..b49abf4335 100644
--- a/meta/lib/oeqa/manual/bsp-qemu.json
+++ b/meta/lib/oeqa/manual/bsp-qemu.json
@@ -1,36 +1,6 @@
[
{
"test": {
- "@alias": "bsps-qemu.bsps-tools.qemu_can_be_started_with_KVM_enabled",
- "author": [
- {
- "email": "alexandru.c.georgescu@intel.com",
- "name": "alexandru.c.georgescu@intel.com"
- }
- ],
- "execution": {
- "1": {
- "action": "Build a kernel with KVM enabled \n\nIn Local.conf add \n\nQEMU_USE_KVM = \"${@ '1' if os.access('/dev/kvm', os.R_OK|os.W_OK) else '0' }\" \n\n ",
- "expected_results": ""
- },
- "2": {
- "action": "Start qemu with option \"kvm\" with runqemu \n a. If you start qemu with kvm failed, maybe it is because host not install kvm and vhost_net module. Follow below link to install them. \n b. vhost_test refer: https://wiki.yoctoproject.org/wiki/Running_an_x86_Yocto_Linux_image_under_QEMU_KVM \n c. kvm refer: https://wiki.yoctoproject.org/wiki/How_to_enable_KVM_for_Poky_qemu",
- "expected_results": ""
- },
- "3": {
- "action": "Check if qemu starts up and if kvm_intel module is used",
- "expected_results": ""
- },
- "4": {
- "action": "If kvm_intel module is not used when starting qemu, it will show 0 in \"Used by\" column when you run \"lsmod | grep kvm_intel\" ",
- "expected_results": "KVM enabled with qemu \nExecute \"lsmod | grep kvm_intel\" from your host twice, before and after you \nstart the qemu with kvm option. Before start, the number should be 0, \nafter start, the number should bigger than 0."
- }
- },
- "summary": "qemu_can_be_started_with_KVM_enabled"
- }
- },
- {
- "test": {
"@alias": "bsps-qemu.bsps-tools.Post-installation_logging",
"author": [
{