aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-06-13 15:58:21 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-16 22:34:12 +0100
commit03179d7a0bbc1fe6a451b7c1e76fd4a10eab574e (patch)
tree9c5218ae8ce98c380ffb2814c69eda4adfad20fd
parentd483c6ab164a7cff7064345d67837da02a934c2a (diff)
downloadopenembedded-core-contrib-03179d7a0bbc1fe6a451b7c1e76fd4a10eab574e.tar.gz
watchdog: disable systemd services by default
systemd has internal support for watchdog. See the RuntimeWatchdogSec in /etc/systemd/system.conf. We'd better just disable this service by default. If users want to use watchdog, consider using the systemd one. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/watchdog/watchdog_5.15.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog_5.15.bb b/meta/recipes-extended/watchdog/watchdog_5.15.bb
index d3f03532ac..bfaed9ad96 100644
--- a/meta/recipes-extended/watchdog/watchdog_5.15.bb
+++ b/meta/recipes-extended/watchdog/watchdog_5.15.bb
@@ -40,6 +40,9 @@ INITSCRIPT_PARAMS_${PN}-keepalive = "start 15 1 2 3 4 5 . stop 85 0 6 ."
SYSTEMD_PACKAGES = "${PN} ${PN}-keepalive"
SYSTEMD_SERVICE_${PN} = "watchdog.service"
SYSTEMD_SERVICE_${PN}-keepalive = "wd_keepalive.service"
+# When using systemd, consider making use of internal watchdog support of systemd.
+# See RuntimeWatchdogSec in /etc/systemd/system.conf.
+SYSTEMD_AUTO_ENABLE = "disable"
do_install_append() {
install -d ${D}${systemd_system_unitdir}