summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbkylerussell@gmail.com <bkylerussell@gmail.com>2023-04-11 13:36:16 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-04-13 11:55:41 +0100
commit231f93becad619f6afa383f9b1132f1d4b02fa64 (patch)
tree77e49afb3679f72fd1818526048447632540c698
parent312393edf0aa5b2c515c08245d1c289ba79bad55 (diff)
downloadopenembedded-core-contrib-231f93becad619f6afa383f9b1132f1d4b02fa64.tar.gz
kernel-devsrc: depend on python3-core instead of python3
Avoids pulling in potential GPLv3 packages through python3-misc catch-all. python3-core is the intended minimal RDEPENDS for packages requiring python3 support. Other python3 module dependencies should be listed explicitly. Signed-off-by: Kyle Russell <bkylerussell@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index b4ea5f756a..6764598d48 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -377,7 +377,7 @@ do_install[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
FILES:${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
FILES:${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
-RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
+RDEPENDS:${PN} = "bc python3-core flex bison ${TCLIBC}-utils"
# 4.15+ needs these next two RDEPENDS
RDEPENDS:${PN} += "openssl-dev util-linux"
# and x86 needs a bit more for 4.15+