summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bartosz.golaszewski@linaro.org>2023-04-13 11:15:57 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-04-14 16:44:22 +0100
commitf4a4de1dc3521695c14dfc206fa4cd0e10c250aa (patch)
tree417b2c7f5e3cd82ccf3e179733efd6dc8aaeafc5
parent7013ddda8f249377c00bc4efb40c34dd5fcfe15a (diff)
downloadopenembedded-core-contrib-f4a4de1dc3521695c14dfc206fa4cd0e10c250aa.tar.gz
python3-build: add missing run-time dependencies
python3-build has several run-time dependencies that are missing from the recipe. This makes it impossible to use the module in self-hosted images. Add missing RDEPENDS. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
-rw-r--r--meta/recipes-devtools/python/python3-build_0.10.0.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-build_0.10.0.bb b/meta/recipes-devtools/python/python3-build_0.10.0.bb
index 770a32023d..b446fa391d 100644
--- a/meta/recipes-devtools/python/python3-build_0.10.0.bb
+++ b/meta/recipes-devtools/python/python3-build_0.10.0.bb
@@ -18,6 +18,15 @@ do_compile:prepend:class-native() {
export PYTHONPATH="${S}/src"
}
-RDEPENDS:${PN} += "python3-packaging python3-pyproject-hooks"
+RDEPENDS:${PN} += " \
+ python3-compression \
+ python3-difflib \
+ python3-ensurepip \
+ python3-logging \
+ python3-packaging \
+ python3-pyproject-hooks \
+ python3-tomllib \
+ python3-venv \
+"
BBCLASSEXTEND = "native nativesdk"