aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2016-11-21 11:04:20 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:48:05 +0000
commit948d50d87af119fc554c11fee70facc2115c03f1 (patch)
treee6da9990e03b82cc4423b214dc31d5dd5c2c9234
parentc47952ea677752b26dc15a3679db23b70b855a3b (diff)
downloadopenembedded-core-contrib-948d50d87af119fc554c11fee70facc2115c03f1.tar.gz
libxml-parser-perl: add expat/Makefile dependency
The file Expat.bs (which is empty!) is created by BOOTSTRAP, but is deleted by INST_DYNAMIC. Make sure we are not creating and deleting it at the same time. (From OE-Core rev: f09e0d857ae917f0a0b393374fb8d6de5a1926e6) Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
index 3acd826868..ab9e5faa51 100644
--- a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
@@ -20,6 +20,8 @@ inherit cpan
do_configure_append() {
sed 's:--sysroot=.*\(\s\|$\):--sysroot=${STAGING_DIR_TARGET} :g' -i Makefile Expat/Makefile
sed 's:^FULL_AR = .*:FULL_AR = ${AR}:g' -i Expat/Makefile
+ # make sure these two do not build in parallel
+ sed 's!^$(INST_DYNAMIC):!$(INST_DYNAMIC): $(BOOTSTRAP)!' -i Expat/Makefile
}
do_compile() {