aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvictor <v.mayoralv@gmail.com>2013-07-03 15:04:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-05 15:34:22 +0100
commit36afee199fd48fbd9d57c808e19b8c2ca9f482d1 (patch)
treeda9df0926812d72433c3479218199106840075ea
parent8e10031d9d5c9c4131d37f7e1b7a3e8fbf5496a7 (diff)
downloadopenembedded-core-contrib-36afee199fd48fbd9d57c808e19b8c2ca9f482d1.tar.gz
apr_cv_mutex_recursive=yes added to apr_1.4.6.bb to make rosnodes work
Working with the meta-ros project we detected that the ROS nodes didn't launch properly the reason was that by default apr_cv_mutex_recursive in apr is set to no and this leads to the APRENOTIMPL return value of apr_thread_mutex_create in thread_mutex.c when APR_THREAD_MUTEX_NESTED is requested via flags. Added CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes" to sources/openembedded-core/meta/recipes-support/apr/apr_1.4.6.bb to fix this issue. It has also been removed the mention of this variable in meta/site/powerpc32-linux. (From OE-Core rev: 20b9151f877978c086dcc8cbae7e0d9c9e89a45d) Signed-off-by: VĂ­ctor Mayoral Vilches <v.mayoralv@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/apr/apr_1.4.6.bb3
-rw-r--r--meta/site/powerpc32-linux1
2 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-support/apr/apr_1.4.6.bb b/meta/recipes-support/apr/apr_1.4.6.bb
index 77dffee12c..fb87d68c9f 100644
--- a/meta/recipes-support/apr/apr_1.4.6.bb
+++ b/meta/recipes-support/apr/apr_1.4.6.bb
@@ -23,6 +23,9 @@ inherit autotools lib_package binconfig multilib_header
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
+CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
+
do_configure_prepend() {
cd ${S}
./buildconf
diff --git a/meta/site/powerpc32-linux b/meta/site/powerpc32-linux
index 251bffe1ef..e3929ac67d 100644
--- a/meta/site/powerpc32-linux
+++ b/meta/site/powerpc32-linux
@@ -203,7 +203,6 @@ apr_cv_use_lfs64=${apr_cv_use_lfs64=yes}
apr_cv_epoll=${apr_cv_epoll=yes}
apr_cv_pthreads_cflags=${apr_cv_pthreads_cflags=-pthread}
apr_cv_pthreads_lib=${apr_cv_pthreads_lib=-lpthread}
-apr_cv_mutex_recursive=${apr_cv_mutex_recursive=yes}
ac_cv_func_mmap=${ac_cv_func_mmap=yes}
ac_cv_file__dev_zero=${ac_cv_file__dev_zero=yes}
ac_cv_sizeof_off_t=${ac_cv_sizeof_off_t=4}