aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-05-18 13:40:46 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-21 22:24:56 +0100
commit7b779c8c2aa43c1a263962f395c2602211ed5159 (patch)
tree09c87a92bee4b031af72fe6cf33ce6b5658f660d
parent5afb6a9cd54769d97ed58a9cbfd33a3e57cb2968 (diff)
downloadopenembedded-core-contrib-7b779c8c2aa43c1a263962f395c2602211ed5159.tar.gz
weston: Add Xwayland initialization support using weston-start
The weston-start script now supports loading modules so the Xwayland support can be loaded optionally. Use this to load Weston accordingly. (From OE-Core rev: 4bbb5d5c0a4bed12622d06cd918ecd4d9db68b5e) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/wayland/weston/xwayland.weston-start7
-rw-r--r--meta/recipes-graphics/wayland/weston_1.10.0.bb7
2 files changed, 13 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston/xwayland.weston-start b/meta/recipes-graphics/wayland/weston/xwayland.weston-start
new file mode 100644
index 0000000000..b483c97cf1
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston/xwayland.weston-start
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if type Xwayland >/dev/null 2>/dev/null; then
+ mkdir -p /tmp/.X11-unix
+
+ add_weston_argument "--modules=xwayland.so"
+fi
diff --git a/meta/recipes-graphics/wayland/weston_1.10.0.bb b/meta/recipes-graphics/wayland/weston_1.10.0.bb
index c9168d7ab8..37a4839e0f 100644
--- a/meta/recipes-graphics/wayland/weston_1.10.0.bb
+++ b/meta/recipes-graphics/wayland/weston_1.10.0.bb
@@ -11,6 +11,7 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
file://make-libwebp-explicitly-configurable.patch \
file://0001-make-error-portable.patch \
file://0001-configure.ac-Fix-wayland-protocols-path.patch \
+ file://xwayland.weston-start \
file://make-weston-launch-exit-for-unrecognized-option.patch \
file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
"
@@ -92,7 +93,11 @@ do_install_append() {
install -d ${D}${datadir}/icons/hicolor/48x48/apps
install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
- fi
+ fi
+
+ if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
+ install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
+ fi
}
PACKAGE_BEFORE_PN += "${PN}-xwayland"