aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-13 16:11:25 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 08:35:01 +0100
commit87d4da4db42b69076384338709d3662b82c0c026 (patch)
tree9686494e8482050b2a3ca39e83e8382ed7374b3e
parent367a102d179a8f43e99817526e803c8aeefb4468 (diff)
downloadopenembedded-core-contrib-87d4da4db42b69076384338709d3662b82c0c026.tar.gz
webkitgtk: do not inherit pythonnative
Set the path to python 2.x explicitly instead; pythonnative and python3native classes cannot be used in the same recipe. (From OE-Core rev: a70f6611baaf6705b85b73feff7babc2494efcbd) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.12.3.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.12.3.bb b/meta/recipes-sato/webkit/webkitgtk_2.12.3.bb
index 265fedb349..a77b086eb3 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.12.3.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.12.3.bb
@@ -21,10 +21,12 @@ SRC_URI = "\
SRC_URI[md5sum] = "aebb4029c09dd81664aa830e4a584c85"
SRC_URI[sha256sum] = "173cbb9a2eca23eee52e99965483ab25aa9c0569ef5b57041fc0c129cc26c307"
-# pythonnative must come after gobject-introspection, otherwise
-# webkit build configuration will not attempt to find Python 2.x after
-# finding (and rejecting) Python 3.x
-inherit cmake lib_package pkgconfig gobject-introspection perlnative pythonnative distro_features_check upstream-version-is-even
+inherit cmake lib_package pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even
+
+# We cannot inherit pythonnative because that would conflict with inheriting python3native
+# (which is done by gobject-introspection). But webkit only needs the path to native Python 2.x binary
+# so we simply set it explicitly here.
+EXTRANATIVEPATH += "python-native"
# depends on libxt
REQUIRED_DISTRO_FEATURES = "x11"