aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-06-13 11:56:34 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 18:05:21 +0100
commit96a993bb4c711a59123af7a86bea26e82ef25d1c (patch)
treeece548b1a28a6ba3ad84c9888f96ee1aa3804678
parent30a289a1f67b4d8f2e678d39e7869034043cd1bb (diff)
downloadopenembedded-core-contrib-96a993bb4c711a59123af7a86bea26e82ef25d1c.tar.gz
linux-yocto/4.1: Always Running Timer Support
Backporting mainline patches to add always running timer support (ART). The main advantage of ART is that ART can be captured simultaneous to the capture of audio and network device clocks, allowing a correlation between timebases to be constructed. Arnd Bergmann (1): ntp/pps: replace getnstime_raw_and_real with 64-bit version Christopher S. Hall (4): time: Add cycles to nanoseconds translation time: Add timekeeping snapshot code capturing system time and counter time: Add driver cross timestamp interface for higher precision time synchronization x86/tsc: Always Running Timer (ART) correlated clocksource DengChao (1): timekeeping: Provide internal function __ktime_get_real_seconds (From OE-Core rev: c38faba29a2d76e8b12f80f7529918388f4e2170) Signed-off-by: Yong, Jonathan <jonathan.yong@intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index ce19bd4345..c609ddc92c 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "0ebcfeb720baaf05db903467d544c88238ef85f2"
+SRCREV_machine ?= "e34d6198589347504e6c8451fc999908f9ce4752"
SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 54a932377b..acdb0dc3c5 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.26"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
+SRCREV_machine ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index c1d9f09344..c785354695 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "5e6960c60bf7c107978312f7e590bdec6676ceb2"
-SRCREV_machine_qemuarm64 ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
-SRCREV_machine_qemumips ?= "9c00d4cf09030ff438033ae094615894f3290628"
-SRCREV_machine_qemuppc ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
-SRCREV_machine_qemux86 ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
-SRCREV_machine_qemux86-64 ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
-SRCREV_machine_qemumips64 ?= "9aaa4d26a05a1816383a1e1dbc11de5830458eec"
-SRCREV_machine ?= "49719d35dca0562ab3e67f37de0d4430dad68a78"
+SRCREV_machine_qemuarm ?= "5049ec1a05cf7c9ff19c892b42d67f17974d3a96"
+SRCREV_machine_qemuarm64 ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
+SRCREV_machine_qemumips ?= "c01dfca5d22960a5b9e4aa47d9c062ecbded5857"
+SRCREV_machine_qemuppc ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
+SRCREV_machine_qemux86 ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
+SRCREV_machine_qemux86-64 ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
+SRCREV_machine_qemumips64 ?= "b8342b84b3a914651c86f3ae463e4f8c6de36da0"
+SRCREV_machine ?= "c9b497be080fcd42adab967fc972f225c9f5b84e"
SRCREV_meta ?= "9f68667031354532563766a3d04ca8a618e9177a"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \