summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-07-20 02:28:23 -0400
committerDengke Du <dengke.du@windriver.com>2016-07-20 02:28:23 -0400
commitab51c283d03e9c021477f0a90d5604e7de1e83ae (patch)
tree0ac11087a00bd8510fc3a46cf761a1a9895b2277
parent5c11e365e19357f721c49d076971567e7b64b61b (diff)
downloadopenembedded-core-contrib-ab51c283d03e9c021477f0a90d5604e7de1e83ae.tar.gz
openembedded-core-contrib-ab51c283d03e9c021477f0a90d5604e7de1e83ae.tar.bz2
openembedded-core-contrib-ab51c283d03e9c021477f0a90d5604e7de1e83ae.zip
LSB: 4.1.0 -> 5.0dengke/LSB_Update_to_5.0
According to the LSB 5.0 Release Notes, FHS Released, Qt3 removed and evoloved its module strategy which you can access from the site: https://wiki.linuxfoundation.org/en/ReleaseNotes50 So we make two changes to comply with the LSB 5.0: 1. Remove the lsb-test-qt3-azov-*.rpm test package and delete the test session. 2. Update the test packages. Signed-off-by: Dengke Du <dengke.du@windriver.com>
-rw-r--r--meta/recipes-extended/lsb/lsbtest/LSB_Test.sh3
-rw-r--r--meta/recipes-extended/lsb/lsbtest/packages_list57
-rw-r--r--meta/recipes-extended/lsb/lsbtest/session9
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb11
4 files changed, 29 insertions, 51 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh b/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
index b9971a17d1..c31a3eb462 100644
--- a/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
+++ b/meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
@@ -113,7 +113,7 @@ fi
#fi
SERVER1="\
- http://${SERVER_NAME}/pub/lsb/base/${LSB_RELEASE}/binary"
+ http://${SERVER_NAME}/pub/lsb/base/released-all/binary"
SERVER2="\
http://${SERVER_NAME}/pub/lsb/test_suites/released-all/binary/runtime"
SERVER3="\
@@ -429,7 +429,6 @@ cat > /etc/rpm/sysinfo/Dirnames << EOF
/opt/lsb/test/desktop/freetype
/opt/lsb/test/desktop/gtkvts
/opt/lsb/test/desktop/libpng
-/opt/lsb/test/desktop/qt3
/opt/lsb/test/desktop/xft
/opt/lsb/test/desktop/xml
/opt/lsb/test/desktop/xrender
diff --git a/meta/recipes-extended/lsb/lsbtest/packages_list b/meta/recipes-extended/lsb/lsbtest/packages_list
index 27d8352d9a..959f931504 100644
--- a/meta/recipes-extended/lsb/lsbtest/packages_list
+++ b/meta/recipes-extended/lsb/lsbtest/packages_list
@@ -1,4 +1,4 @@
-LSB_RELEASE="released-4.1.0"
+LSB_RELEASE="released-5.0"
LSB_ARCH="lsbarch"
BASE_PACKAGES_LIST="lsb-setup-4.1.0-1.noarch.rpm"
@@ -9,36 +9,35 @@ RUNTIME_BASE_PACKAGES_LIST="lsb-dist-checker-5.0.0.1-1.targetarch.rpm \
lsb-xvfb-1.2.0-22.targetarch.rpm \
"
-RUNTIME_PACKAGES_LIST="lsb-cmdchk-4.1.4-5.targetarch.rpm \
- lsb-libchk-4.1.4-5.targetarch.rpm \
- lsb-qm-2.2-12.lsb4.targetarch.rpm \
- lsb-task-dist-testkit-4.1.9-1.noarch.rpm \
- lsb-test-core-4.1.15-1.targetarch.rpm \
- lsb-test-cpp-t2c-4.1.0-1.targetarch.rpm \
- lsb-test-desktop-4.1.9-1.targetarch.rpm \
- lsb-test-desktop-t2c-4.1.3-3.targetarch.rpm \
- lsb-test-libstdcpp-4.1.0-18.lsb4.targetarch.rpm \
- lsb-test-olver-core-4.1.4-1.targetarch.rpm \
- lsb-test-perl-4.1.8-1.noarch.rpm \
- lsb-test-printing-4.1.2-1.targetarch.rpm \
- lsb-test-python-4.1.5-1.targetarch.rpm \
- lsb-test-qt3-azov-4.1.1-3.targetarch.rpm \
- lsb-test-qt4-azov-4.1.3-1.targetarch.rpm \
- lsb-test-xts5-5.1.5-45.lsb4.targetarch.rpm \
- lsb-test-alsa-t2c-4.1.0-1.targetarch.rpm \
- lsb-test-core-t2c-4.1.2-3.targetarch.rpm \
- lsb-test-xml2-azov-4.1.0-1.targetarch.rpm \
+RUNTIME_PACKAGES_LIST="lsb-cmdchk-5.0.3-1.targetarch.rpm \
+ lsb-libchk-5.0.3-1.targetarch.rpm \
+ lsb-qm-2.2-1.lsb5.targetarch.rpm \
+ lsb-task-dist-testkit-5.0.0-2.noarch.rpm \
+ lsb-test-core-5.0.1-1.targetarch.rpm \
+ lsb-test-cpp-t2c-5.0.0-1.targetarch.rpm \
+ lsb-test-desktop-5.0.0-1.targetarch.rpm \
+ lsb-test-desktop-t2c-5.0.0-1.targetarch.rpm \
+ lsb-test-libstdcpp-4.1.0-22.lsb1.targetarch.rpm \
+ lsb-test-olver-core-5.0.0-1.targetarch.rpm \
+ lsb-test-perl-5.0.2-1.noarch.rpm \
+ lsb-test-printing-5.0.1-1.targetarch.rpm \
+ lsb-test-python-5.0.0-1.targetarch.rpm \
+ lsb-test-qt4-azov-5.0.0-1.targetarch.rpm \
+ lsb-test-xts5-5.1.5-47.lsb5.targetarch.rpm \
+ lsb-test-alsa-t2c-5.1.91-4.targetarch.rpm \
+ lsb-test-core-t2c-5.0.1-1.targetarch.rpm \
+ lsb-test-xml2-azov-5.0.0-1.targetarch.rpm \
"
-APP_PACKAGES_LIST="lsb-python-2.4.6-7.lsb4.targetarch.rpm \
- lsb-apache-2.2.14-8.lsb4.targetarch.rpm \
- lsb-tcl-8.5.7-8.lsb4.targetarch.rpm \
- lsb-expect-5.43.0-13.lsb4.targetarch.rpm \
- lsb-groff-1.20.1-7.lsb4.targetarch.rpm \
- lsb-raptor-1.4.19-5.lsb4.targetarch.rpm \
- lsb-xpdf-1.01-14.lsb4.targetarch.rpm \
- lsb-samba-3.4.3-9.lsb4.targetarch.rpm \
- lsb-rsync-3.0.6-6.lsb4.targetarch.rpm \
+APP_PACKAGES_LIST="lsb-python-2.4.6-10.lsb5.targetarch.rpm \
+ lsb-apache-2.2.19-5.lsb5.targetarch.rpm \
+ lsb-tcl-8.5.9-21.lsb5.targetarch.rpm \
+ lsb-expect-5.43.0-21.lsb5.targetarch.rpm \
+ lsb-groff-1.20.1-9.lsb5.targetarch.rpm \
+ lsb-raptor-1.4.21-4.lsb5.targetarch.rpm \
+ lsb-xpdf-1.01-17.lsb5.targetarch.rpm \
+ lsb-samba-3.5.9-5.lsb5.targetarch.rpm \
+ lsb-rsync-3.0.8-3.lsb5.targetarch.rpm \
"
APP_TESTFILES_LIST="expect-tests.tar \
diff --git a/meta/recipes-extended/lsb/lsbtest/session b/meta/recipes-extended/lsb/lsbtest/session
index 85ca2efe92..3abcca740b 100644
--- a/meta/recipes-extended/lsb/lsbtest/session
+++ b/meta/recipes-extended/lsb/lsbtest/session
@@ -126,15 +126,6 @@ VERSION: local|*
AUTOREPLY_TESTSUITE_DIR: /opt/lsb/test/python
AUTOREPLY_RESULTS_DIR: /opt/lsb/test/python/results
-[qt3-azov]
-RUN: 1
-VERSION: local|*
-
-[qt3-azov|local|*]
-AUTOREPLY_TESTSUITE_DIR: /opt/lsb/test/qt3-azov
-AUTOREPLY_X11_FONT_PATH: [default]
-AUTOREPLY_RESULTS_DIR: /opt/lsb/test/qt3-azov/results
-
[qt4-azov]
RUN: 1
VERSION: local|*
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index 5a32c52ec5..29564e0c9d 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -200,16 +200,6 @@ RDEPENDS_packagegroup-core-lsb-python = "\
python-misc \
"
-def get_libqt3(d):
- if 'linuxstdbase' in d.getVar('DISTROOVERRIDES', False) or "":
- if 'qt3' in d.getVar('BBFILE_COLLECTIONS', False) or "":
- return 'libqt-mt3'
-
- bb.warn('The meta-qt3 layer should be added, this layer provides Qt 3.x ' \
- 'libraries. Its intended use is for passing LSB tests as Qt3 is ' \
- 'a requirement for LSB.')
- return ''
-
QT4PKGS = " \
libqtcore4 \
libqtgui4 \
@@ -254,7 +244,6 @@ RDEPENDS_packagegroup-core-lsb-desktop = "\
atk \
libasound \
${@get_libqt4(d)} \
- ${@get_libqt3(d)} \
"
RDEPENDS_packagegroup-core-lsb-runtime-add = "\