aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-05-18 13:40:42 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-21 22:24:55 +0100
commitd46c5beedca8630e5080401925cb7902edf55efe (patch)
treeab2a70fbaf3432f8cfab498200c43a3d32bec648
parent959237ef882d0abc03a8ad4449c4ce8efe4b18e5 (diff)
downloadopenembedded-core-contrib-d46c5beedca8630e5080401925cb7902edf55efe.tar.gz
weston-init: Rework do_install to use install -D option
The install -D allow for the parent directories to be created in a single command line, reducing the code and number of fork during the build. (From OE-Core rev: 9d745d7c958402fa1d59c9d0267b58a05d7ee4b3) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 653541e3c8..4ad62cff2d 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -8,11 +8,8 @@ SRC_URI = "file://init \
S = "${WORKDIR}"
do_install() {
- install -d ${D}/${sysconfdir}/init.d
- install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
-
- install -d ${D}${systemd_system_unitdir}
- install -m0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}
+ install -Dm755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
+ install -Dm0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
}
inherit allarch update-rc.d distro_features_check systemd