aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-02 12:26:03 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-03 13:13:28 +0100
commiteb80ec901259c64a06793e036a485f75c58d8ff2 (patch)
tree7637f0af23ca8e59382ff63b5cda6637dba0ab86
parent8fdb4be2c88ccc8b648c013664dbdde22b8d2d32 (diff)
downloadopenembedded-core-contrib-eb80ec901259c64a06793e036a485f75c58d8ff2.tar.gz
lttng-ust: move to Python 3
(From OE-Core rev: f49beaf99171e081a0e5df50d38a1122045ca029) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_git.bb b/meta/recipes-kernel/lttng/lttng-ust_git.bb
index 15d925d29e..f5a12b10b0 100644
--- a/meta/recipes-kernel/lttng/lttng-ust_git.bb
+++ b/meta/recipes-kernel/lttng/lttng-ust_git.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
inherit autotools lib_package
DEPENDS = "liburcu util-linux"
-RDEPENDS_${PN}-bin = "python-core"
+RDEPENDS_${PN}-bin = "python3-core"
# For backwards compatibility after rename
RPROVIDES_${PN} = "lttng2-ust"
@@ -27,6 +27,13 @@ SRC_URI = "git://git.lttng.org/lttng-ust.git;branch=stable-2.7 \
file://lttng-ust-add-support-for-aarch64_be.patch \
"
+do_install_append() {
+ # Patch python tools to use Python 3; they should be source compatible, but
+ # still refer to Python 2 in the shebang
+ sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
+}
+
+
S = "${WORKDIR}/git"
do_configure_prepend () {