aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-10-26 11:37:38 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-01 10:05:45 +0000
commita1668c8721709f3d1bc0078737514111e1985bdd (patch)
tree8c9324a2f17f5c92dd74e89620752f2cf2b1fad3
parent95502c3a58d6441f1ac9417186dee1c4e13f3abc (diff)
downloadopenembedded-core-contrib-a1668c8721709f3d1bc0078737514111e1985bdd.tar.gz
conf: Use xf86-input-libinput by default
Don't install legacy X input drivers for any machines by default, RRECOMMEND xf86-input-libinput instead. This is the setup suggested by upstream: install only libinput by default, but let niche legacy drivers sort higher in configuration so they get chosen if installed. So the order is: evdev < libinput < (synaptics|vmmouse|...) This also removes vmmouse X driver from the qemu config. If a VMware virtual mouse device really needs to be supported, we should enable CONFIG_MOUSE_PS2_VMMOUSE in kernel instead: that is directly supported by the libinput X driver. Fixes [YOCTO #10195]. (From OE-Core rev: 2d005faff6341a81a2afae28860101ba9db51ae8) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/machine/include/qemu.inc4
-rw-r--r--meta/conf/machine/include/x86-base.inc4
-rw-r--r--meta/conf/machine/qemux86-64.conf3
-rw-r--r--meta/conf/machine/qemux86.conf3
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb2
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg.inc2
6 files changed, 3 insertions, 15 deletions
diff --git a/meta/conf/machine/include/qemu.inc b/meta/conf/machine/include/qemu.inc
index 2bc4dc2db6..0e4103bad7 100644
--- a/meta/conf/machine/include/qemu.inc
+++ b/meta/conf/machine/include/qemu.inc
@@ -6,10 +6,8 @@ PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
XSERVER ?= "xserver-xorg \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-swrast xserver-xorg-extension-glx', '', d)} \
- xf86-input-evdev \
- xf86-input-mouse \
xf86-video-fbdev \
- xf86-input-keyboard"
+ "
MACHINE_FEATURES = "alsa bluetooth usbgadget screen"
diff --git a/meta/conf/machine/include/x86-base.inc b/meta/conf/machine/include/x86-base.inc
index 479e89e548..40d59577fd 100644
--- a/meta/conf/machine/include/x86-base.inc
+++ b/meta/conf/machine/include/x86-base.inc
@@ -26,10 +26,6 @@ PREFERRED_VERSION_linux-yocto ??= "4.8%"
# XSERVER subcomponents, used to build the XSERVER variable
#
XSERVER_X86_BASE = "xserver-xorg \
- xf86-input-mouse \
- xf86-input-keyboard \
- xf86-input-evdev \
- xf86-input-synaptics \
"
XSERVER_X86_EXT = " \
diff --git a/meta/conf/machine/qemux86-64.conf b/meta/conf/machine/qemux86-64.conf
index b191ddd3cb..f2b2aebf95 100644
--- a/meta/conf/machine/qemux86-64.conf
+++ b/meta/conf/machine/qemux86-64.conf
@@ -18,9 +18,6 @@ SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
XSERVER = "xserver-xorg \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-swrast xserver-xorg-extension-glx', '', d)} \
- xf86-input-vmmouse \
- xf86-input-keyboard \
- xf86-input-evdev \
xf86-video-cirrus \
xf86-video-fbdev \
xf86-video-vmware \
diff --git a/meta/conf/machine/qemux86.conf b/meta/conf/machine/qemux86.conf
index 8555fd6bfe..09555ad548 100644
--- a/meta/conf/machine/qemux86.conf
+++ b/meta/conf/machine/qemux86.conf
@@ -17,9 +17,6 @@ SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1"
XSERVER = "xserver-xorg \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-swrast xserver-xorg-extension-glx', '', d)} \
- xf86-input-vmmouse \
- xf86-input-keyboard \
- xf86-input-evdev \
xf86-video-cirrus \
xf86-video-fbdev \
xf86-video-vmware \
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
index 6b50028562..97dcac5f79 100644
--- a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
@@ -11,7 +11,7 @@ inherit packagegroup distro_features_check
# rdepends on XSERVER
REQUIRED_DISTRO_FEATURES = "x11"
-XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+XSERVER ?= "xserver-xorg xf86-video-fbdev"
XSERVERCODECS ?= ""
RDEPENDS_${PN} = "\
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc b/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
index 29503b1a53..269fa63048 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
@@ -71,7 +71,7 @@ PACKAGES =+ "${PN}-sdl \
SUMMARY_xf86-video-modesetting = "X.Org X server -- modesetting display driver"
INSANE_SKIP_${MLPREFIX}xf86-video-modesetting = "xorg-driver-abi"
-XSERVER_RRECOMMENDS = "xkeyboard-config rgb xserver-xf86-config xkbcomp"
+XSERVER_RRECOMMENDS = "xkeyboard-config rgb xserver-xf86-config xkbcomp xf86-input-libinput"
RRECOMMENDS_${PN} += "${XSERVER_RRECOMMENDS}"
RRECOMMENDS_${PN}-xwayland += "${XSERVER_RRECOMMENDS}"
RDEPENDS_${PN}-xvfb += "xkeyboard-config"