aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-15 18:50:50 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-15 18:50:50 +0100
commit4385b6e36cd409a787827a5d5ff2e8e943d7a902 (patch)
tree53a18997318a8a10cf4591f647b606aed039cddd
parentac2942e80e4982463b59290e2d9086e502eb4b01 (diff)
downloadopenembedded-core-contrib-4385b6e36cd409a787827a5d5ff2e8e943d7a902.tar.gz
ti-local-power-manager: avoid parse errors when variables aren't defined
This fixes: ERROR: Error parsing /home/kraj/work/setup-scripts/sources/angstrom-layers/BSP/TI/recipes-ti/local-power-manager/ti-local-power-manager_1.24.02.09.bb: LexToken(PIPE,'|',0,0) followed by: LexToken(TOKEN,'sed',0,0) LexToken(TOKEN,'s:\\\\.:_:g',0,0) ERROR: Command execution failed: Exited with 1 As reported by Khem Raj Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-ti/local-power-manager/ti-local-power-manager.inc6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-ti/local-power-manager/ti-local-power-manager.inc b/recipes-ti/local-power-manager/ti-local-power-manager.inc
index 836e118147..6b2e34373c 100644
--- a/recipes-ti/local-power-manager/ti-local-power-manager.inc
+++ b/recipes-ti/local-power-manager/ti-local-power-manager.inc
@@ -26,11 +26,11 @@ DEPENDS += "virtual/kernel"
LPMDSPPOWERSOC_omap3 = "omap3530"
LPMDSPPOWERSOC_dm6446 = "dm6446"
-LPMDSPPOWERSOC ?= "<UNDEFINED_LPMDSPPOWERSOC>"
+LPMDSPPOWERSOC ?= "UNDEFINED_LPMDSPPOWERSOC"
XDC_PLATFORM_dm6446 = "ti.platforms.evmDM6446"
XDC_PLATFORM_omap3 = "ti.platforms.evm3530"
-XDC_PLATFORM ?= "<UNDEFINED_XDC_PLATFORM>"
+XDC_PLATFORM ?= "UNDEFINED_XDC_PLATFORM"
do_configure () {
@@ -100,7 +100,7 @@ do_install () {
# Install the Utilities
install -d ${D}/${installdir}/ti-lpm-utils
- install -m 0755 ${S}/packages/ti/bios/power/utils/bin/$(echo ${XDC_PLATFORM} | sed s:\\.:_:g)/linux/release/* ${D}/${installdir}/ti-lpm-utils
+ install -m 0755 ${S}/packages/ti/bios/power/utils/bin/$(echo ${XDC_PLATFORM} | tr . _)/linux/release/* ${D}/${installdir}/ti-lpm-utils
# Install/Stage the Source Tree
install -d ${D}${LPM_INSTALL_DIR_RECIPE}