summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-26 09:18:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-28 08:24:20 +0100
commit2ee962186176c5ecb34c670e76415d4321affe76 (patch)
tree314552cf7736a1f32a65404aa87e8d1ab994f63e
parentc5774fca09de12b29b1f9062e41c71db6abc972b (diff)
downloadopenembedded-core-contrib-2ee962186176c5ecb34c670e76415d4321affe76.tar.gz
mesa: update 20.0.7 -> 20.1.2
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch12
-rw-r--r--meta/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch16
-rw-r--r--meta/recipes-graphics/mesa/mesa-gl_20.1.2.bb (renamed from meta/recipes-graphics/mesa/mesa-gl_20.0.7.bb)0
-rw-r--r--meta/recipes-graphics/mesa/mesa.inc3
-rw-r--r--meta/recipes-graphics/mesa/mesa_20.1.2.bb (renamed from meta/recipes-graphics/mesa/mesa_20.0.7.bb)1
5 files changed, 15 insertions, 17 deletions
diff --git a/meta/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch b/meta/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
index cd35a1f850..91e59d14ed 100644
--- a/meta/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
+++ b/meta/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
@@ -1,4 +1,4 @@
-From df835389699b32bb6610b39972502e323f8e09e5 Mon Sep 17 00:00:00 2001
+From dd1d15c75f6ff8ee96cf1e7b74e582bff3183ef6 Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
Date: Thu, 14 Nov 2019 13:08:31 -0800
Subject: [PATCH] meson.build: make TLS ELF optional
@@ -15,10 +15,10 @@ Signed-off-by: Alistair Francis <alistair@alistair23.me>
2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index 09e3759..a954118 100644
+index 261b588..311436e 100644
--- a/meson.build
+++ b/meson.build
-@@ -387,7 +387,7 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
+@@ -392,7 +392,7 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
@@ -28,10 +28,10 @@ index 09e3759..a954118 100644
endif
diff --git a/meson_options.txt b/meson_options.txt
-index 626baf3..637ff14 100644
+index ab43150..d7b1555 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -341,6 +341,12 @@ option(
+@@ -355,6 +355,12 @@ option(
value : true,
description : 'Enable direct rendering in GLX and EGL for DRI',
)
@@ -42,5 +42,5 @@ index 626baf3..637ff14 100644
+ description : 'Enable TLS support in ELF',
+)
option(
- 'I-love-half-baked-turnips',
+ 'prefer-iris',
type : 'boolean',
diff --git a/meta/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch b/meta/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch
index 901feca556..dacb1ea1c8 100644
--- a/meta/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch
+++ b/meta/recipes-graphics/mesa/files/0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch
@@ -1,4 +1,4 @@
-From 38a313474e127d61e749866423e708fc86ed9ec5 Mon Sep 17 00:00:00 2001
+From 281a636353666bfdd373c62591e744087e750e89 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 4 Dec 2019 14:15:28 -0800
Subject: [PATCH] vc4: use intmax_t for formatted output of timespec members
@@ -13,13 +13,14 @@ error: format specifies type 'long' but the argument has type 'time_t' (aka 'lon
Upstream-Status: Submitted [https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2966]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
src/gallium/drivers/v3d/v3d_bufmgr.c | 4 ++--
src/gallium/drivers/vc4/vc4_bufmgr.c | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/src/gallium/drivers/v3d/v3d_bufmgr.c b/src/gallium/drivers/v3d/v3d_bufmgr.c
-index b3e4d053cc0..c514bf00bf0 100644
+index 31a0803..cc2e2af 100644
--- a/src/gallium/drivers/v3d/v3d_bufmgr.c
+++ b/src/gallium/drivers/v3d/v3d_bufmgr.c
@@ -80,8 +80,8 @@ v3d_bo_dump_stats(struct v3d_screen *screen)
@@ -27,27 +28,24 @@ index b3e4d053cc0..c514bf00bf0 100644
struct timespec time;
clock_gettime(CLOCK_MONOTONIC, &time);
- fprintf(stderr, " now: %ld\n",
-- time.tv_sec);
+- (long)time.tv_sec);
+ fprintf(stderr, " now: %jd\n",
+ (intmax_t)time.tv_sec);
}
}
diff --git a/src/gallium/drivers/vc4/vc4_bufmgr.c b/src/gallium/drivers/vc4/vc4_bufmgr.c
-index 5ec360934c0..bf05f6cadd6 100644
+index a786e8e..975d49e 100644
--- a/src/gallium/drivers/vc4/vc4_bufmgr.c
+++ b/src/gallium/drivers/vc4/vc4_bufmgr.c
-@@ -107,8 +107,8 @@ vc4_bo_dump_stats(struct vc4_screen *screen)
+@@ -99,8 +99,8 @@ vc4_bo_dump_stats(struct vc4_screen *screen)
struct timespec time;
clock_gettime(CLOCK_MONOTONIC, &time);
- fprintf(stderr, " now: %ld\n",
-- time.tv_sec);
+- (long)time.tv_sec);
+ fprintf(stderr, " now: %jd\n",
+ (intmax_t)time.tv_sec);
}
}
---
-2.24.0
-
diff --git a/meta/recipes-graphics/mesa/mesa-gl_20.0.7.bb b/meta/recipes-graphics/mesa/mesa-gl_20.1.2.bb
index e50782be1c..e50782be1c 100644
--- a/meta/recipes-graphics/mesa/mesa-gl_20.0.7.bb
+++ b/meta/recipes-graphics/mesa/mesa-gl_20.1.2.bb
diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index 965e12d17e..4fe5f025eb 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -23,8 +23,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \
"
-SRC_URI[md5sum] = "609cb7664204e031d4c65c602c652a28"
-SRC_URI[sha256sum] = "fe6e258fe772c3cd2ac01741bf7408058c3ac02d66acff9a6e669bd72e3ea178"
+SRC_URI[sha256sum] = "283dff72814c8a80ce1ff8271e3f055895d26f4da3f4362acc49193e635780cb"
UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
diff --git a/meta/recipes-graphics/mesa/mesa_20.0.7.bb b/meta/recipes-graphics/mesa/mesa_20.1.2.bb
index d17d9eb04b..96e8aa38d6 100644
--- a/meta/recipes-graphics/mesa/mesa_20.0.7.bb
+++ b/meta/recipes-graphics/mesa/mesa_20.1.2.bb
@@ -1 +1,2 @@
require ${BPN}.inc
+