summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-07 21:10:06 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-08 23:49:32 +0100
commit6936e44d10bbad1fae46406943db490791739f87 (patch)
treefabd3a8840ec940e05a8d6da883f57fb251e639b
parentdd660e5c3fb74f7c4b7b8e863f7143066ae22813 (diff)
downloadopenembedded-core-contrib-6936e44d10bbad1fae46406943db490791739f87.tar.gz
libgcrypt: Fix reproducibility issues in ptest
The recent ptest addition was causing reproducibility tests to fail. Remove the problematic files as they clearly aren't needed on target to run the ptests. Hack the Makefile so that it doesn't try to rerun configure and similar. Also add a missing dependency on make. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
index f9dc52393f..f7108013d3 100644
--- a/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
+++ b/meta/recipes-support/libgcrypt/libgcrypt_1.10.1.bb
@@ -17,7 +17,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
DEPENDS = "libgpg-error"
-RDEPENDS:${PN}-ptest = "bash"
+RDEPENDS:${PN}-ptest = "bash make"
UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
@@ -60,6 +60,12 @@ do_install_ptest() {
cp -r --preserve=mode,links -v ${B} ${D}${PTEST_PATH}
rm ${D}${PTEST_PATH}/build/cipher/gost-s-box
rm ${D}${PTEST_PATH}/build/doc/yat2m
+ rm ${D}${PTEST_PATH}/build/libtool
+ rm ${D}${PTEST_PATH}/build/config.status
+ rm ${D}${PTEST_PATH}/build/config.log
+ rm ${D}${PTEST_PATH}/build/src/mpicalc
+ rm ${D}${PTEST_PATH}/${BP}/autom4te* -rf
+ sed -i -e 's/Makefile:.*/Makefile-disabled:/' ${D}${PTEST_PATH}/build/Makefile
find ${D}/${PTEST_PATH}/build -name "*.cmake" -or -name "Makefile" \
| xargs sed -e "s|${WORKDIR}|${PTEST_PATH}|g" -e "s|${WORKDIR}/recipe-sysroot-native||g" -i
}