summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-16 12:45:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-16 16:35:06 +0100
commit2ade2c53388c92d36b8b30dae30670fd96ca4821 (patch)
treed5f0f81207002fb8c0abef062f3a72144124c2b4
parent0c68c621d3b8690e3a346170006f75b032511a8a (diff)
downloadopenembedded-core-contrib-2ade2c53388c92d36b8b30dae30670fd96ca4821.tar.gz
gettext/flex/m4/bzip2/gzip/parted/slang/attr: Add make to -ptest packages
This solves ptest runtime errors where make was missing causing the ptests to fail. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/gettext/gettext_0.19.8.1.bb1
-rw-r--r--meta/recipes-devtools/flex/flex_2.6.0.bb2
-rw-r--r--meta/recipes-devtools/m4/m4-1.4.18.inc2
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.6.bb2
-rw-r--r--meta/recipes-extended/gzip/gzip_1.10.bb2
-rw-r--r--meta/recipes-extended/parted/parted_3.2.bb2
-rw-r--r--meta/recipes-extended/slang/slang_2.3.2.bb2
-rw-r--r--meta/recipes-support/attr/attr.inc2
8 files changed, 12 insertions, 3 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.19.8.1.bb b/meta/recipes-core/gettext/gettext_0.19.8.1.bb
index 627568bc3f..30121ad23e 100644
--- a/meta/recipes-core/gettext/gettext_0.19.8.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.19.8.1.bb
@@ -166,6 +166,7 @@ do_install_ptest() {
fi
}
+RDEPENDS_${PN}-ptest += "make"
RDEPENDS_${PN}-ptest_append_libc-glibc = "\
glibc-gconv-big5 \
glibc-charmap-big5 \
diff --git a/meta/recipes-devtools/flex/flex_2.6.0.bb b/meta/recipes-devtools/flex/flex_2.6.0.bb
index b89b7515b5..b477cd8c7f 100644
--- a/meta/recipes-devtools/flex/flex_2.6.0.bb
+++ b/meta/recipes-devtools/flex/flex_2.6.0.bb
@@ -48,7 +48,7 @@ PACKAGES =+ "${PN}-libfl"
FILES_${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
RDEPENDS_${PN} += "m4"
-RDEPENDS_${PN}-ptest += "bash gawk"
+RDEPENDS_${PN}-ptest += "bash gawk make"
do_compile_ptest() {
oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
diff --git a/meta/recipes-devtools/m4/m4-1.4.18.inc b/meta/recipes-devtools/m4/m4-1.4.18.inc
index f433b3f2dd..af0ff45863 100644
--- a/meta/recipes-devtools/m4/m4-1.4.18.inc
+++ b/meta/recipes-devtools/m4/m4-1.4.18.inc
@@ -52,6 +52,8 @@ do_install_ptest() {
${D}${PTEST_PATH}/tests/test-xalloc-die
}
+
+RDEPENDS_${PN}-ptest += "make"
RDEPENDS_${PN}-ptest_append_libc-glibc = "\
locale-base-fr-fr.iso-8859-1 \
"
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
index 7d04e30d53..15a8e51550 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
@@ -40,6 +40,8 @@ do_install_ptest () {
FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
+RDEPENDS_${PN}-ptest += "make"
+
PROVIDES_append_class-native = " bzip2-replacement-native"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/gzip/gzip_1.10.bb b/meta/recipes-extended/gzip/gzip_1.10.bb
index 75de970631..6a5b2459e6 100644
--- a/meta/recipes-extended/gzip/gzip_1.10.bb
+++ b/meta/recipes-extended/gzip/gzip_1.10.bb
@@ -12,6 +12,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
PROVIDES_append_class-native = " gzip-replacement-native"
+RDEPENDS_${PN}-ptest += "make"
+
BBCLASSEXTEND = "native"
inherit ptest
diff --git a/meta/recipes-extended/parted/parted_3.2.bb b/meta/recipes-extended/parted/parted_3.2.bb
index 6189fd2246..ceac52892d 100644
--- a/meta/recipes-extended/parted/parted_3.2.bb
+++ b/meta/recipes-extended/parted/parted_3.2.bb
@@ -47,7 +47,7 @@ do_install_ptest() {
sed -e 's| ../parted||' -i $t/tests/*.sh
}
-RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3"
+RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make"
inherit update-alternatives
diff --git a/meta/recipes-extended/slang/slang_2.3.2.bb b/meta/recipes-extended/slang/slang_2.3.2.bb
index e53c4321b9..e329310937 100644
--- a/meta/recipes-extended/slang/slang_2.3.2.bb
+++ b/meta/recipes-extended/slang/slang_2.3.2.bb
@@ -75,6 +75,8 @@ do_install_ptest() {
FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/"
+RDEPENDS_${PN}-ptest += "make"
+
PARALLEL_MAKE = ""
PARALLEL_MAKEINST = ""
diff --git a/meta/recipes-support/attr/attr.inc b/meta/recipes-support/attr/attr.inc
index cfa38a7196..1a29eb339e 100644
--- a/meta/recipes-support/attr/attr.inc
+++ b/meta/recipes-support/attr/attr.inc
@@ -41,6 +41,6 @@ do_install_ptest() {
sed -e 's|; @echo|; echo|' -i ${D}${PTEST_PATH}/test/Makefile
}
-RDEPENDS_${PN}-ptest = "attr coreutils perl-module-filehandle perl-module-getopt-std perl-module-posix"
+RDEPENDS_${PN}-ptest = "attr coreutils perl-module-filehandle perl-module-getopt-std perl-module-posix make"
BBCLASSEXTEND = "native nativesdk"