summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2023-03-22 00:45:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-22 23:17:24 +0000
commit2c6388e5bbf45a71891aa90047eef980d8a27c9d (patch)
treee048807a9950ebb4f1ad14c0075db1732aa56216
parente9f0070631b032a143b765874a228674c19d0304 (diff)
downloadopenembedded-core-contrib-2c6388e5bbf45a71891aa90047eef980d8a27c9d.tar.gz
rpm: fix RPM_ETCCONFIGDIR value in SDK
The RPM_ETCCONFIGDIR should be some root directory instead of the etc directory as in patch 0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch RPM_ETCCONFIGDIR is used to prefix /etc. The regression was introduced in the following patch. """ nativesdk-rpm: export RPM_ETCCONFIGDIR and MAGIC in environment like RPM_CONFIGDIR """ The patch incorrectly set RPM_ETCCONFIGDIR, maybe because this variable's name is a little misleading. Note that this patch modifies both RPM_ETCCONFIGDIR and RPM_CONFIGDIR. The RPM_CONFIGDIR's value happened to be correct because of the ${libdir}, not $OECORE_NATIVE_SYSROOT. In fact, due to the substitution mechanism, the $OECORE_NATIVE_SYSROOT is empty. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.18.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.18.0.bb b/meta/recipes-devtools/rpm/rpm_4.18.0.bb
index be81c3eb08..cdb4f227f4 100644
--- a/meta/recipes-devtools/rpm/rpm_4.18.0.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.18.0.bb
@@ -122,8 +122,8 @@ do_install:append:class-nativesdk() {
mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
cat <<- EOF > ${D}${SDKPATHNATIVE}/environment-setup.d/rpm.sh
- export RPM_CONFIGDIR="$OECORE_NATIVE_SYSROOT${libdir}/rpm"
- export RPM_ETCCONFIGDIR="$OECORE_NATIVE_SYSROOT${sysconfdir}"
+ export RPM_CONFIGDIR="${libdir}/rpm"
+ export RPM_ETCCONFIGDIR="${SDKPATHNATIVE}"
export RPM_NO_CHROOT_FOR_SCRIPTS=1
EOF
}