aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-03-22 10:53:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-05 15:11:15 +0100
commita57e3e387a962a253e8f4f1519141eb7f8ce5e41 (patch)
tree0547ebb2e91eddd560db9072617af360986ac6be
parent5055bcabca542074cad00c92edf79f3a1551ac32 (diff)
downloadopenembedded-core-contrib-a57e3e387a962a253e8f4f1519141eb7f8ce5e41.tar.gz
grub-efi: fix build failure
grub-efi build fails with the following error on Fedora 26: | ../grub-2.00/util/raid.c: In function 'grub_util_raid_getmembers': | ../grub-2.00/util/raid.c:91:13: error: In the GNU C Library, "makedev" is defined | by <sys/sysmacros.h>. For historical compatibility, it is | currently defined by <sys/types.h> as well, but we plan to | remove this soon. To use "makedev", include <sys/sysmacros.h> | directly. If you did not intend to use a system-defined macro | "makedev", you should undefine it after including <sys/types.h>. [-Werror] | makedev (disk.major, disk.minor)); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Resolve the build error by backporting the fix from upstream. [YOCTO #12595] Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-bsp/grub/files/0001-configure-fix-check-for-sys-sysmacros.h-under-glibc-.patch48
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.00.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/files/0001-configure-fix-check-for-sys-sysmacros.h-under-glibc-.patch b/meta/recipes-bsp/grub/files/0001-configure-fix-check-for-sys-sysmacros.h-under-glibc-.patch
new file mode 100644
index 0000000000..23717e3859
--- /dev/null
+++ b/meta/recipes-bsp/grub/files/0001-configure-fix-check-for-sys-sysmacros.h-under-glibc-.patch
@@ -0,0 +1,48 @@
+From 07662af7aed55bcec448bc2a6610de1f0cb62100 Mon Sep 17 00:00:00 2001
+From: Andrei Borzenkov <arvidjaar@gmail.com>
+Date: Thu, 22 Dec 2016 22:48:25 +0300
+Subject: [PATCH] configure: fix check for sys/sysmacros.h under glibc 2.25+
+
+glibc 2.25 still includes sys/sysmacros.h in sys/types.h but also emits
+deprecation warning. So test for sys/types.h succeeds in configure but later
+compilation fails because we use -Werror by default.
+
+While this is fixed in current autoconf GIT, we really cannot force everyone
+to use bleeding edge (that is not even released right now). So run test under
+-Werror as well to force proper detection.
+
+This should have no impact on autoconf 2.70+ as AC_HEADER_MAJOR in this version
+simply checks for header existence.
+
+Upstream-Status: Backport [http://git.savannah.gnu.org/cgit/grub.git/commit/?id=07662af7aed55bcec448bc2a6610de1f0cb62100]
+
+Reported and tested by Khem Raj <raj.khem@gmail.com>
+
+Signed-off-by: Andrei Borzenkov <arvidjaar@gmail.com>
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
+---
+ configure.ac | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index dc56564..4e980c5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -389,7 +389,14 @@ fi
+ # Check for functions and headers.
+ AC_CHECK_FUNCS(posix_memalign memalign getextmntent)
+ AC_CHECK_HEADERS(sys/param.h sys/mount.h sys/mnttab.h limits.h)
++
++# glibc 2.25 still includes sys/sysmacros.h in sys/types.h but emits deprecation
++# warning which causes compilation failure later with -Werror. So use -Werror here
++# as well to force proper sys/sysmacros.h detection.
++SAVED_CFLAGS="$CFLAGS"
++CFLAGS="$HOST_CFLAGS -Werror"
+ AC_HEADER_MAJOR
++CFLAGS="$SAVED_CFLAGS"
+
+ AC_CHECK_MEMBERS([struct statfs.f_fstypename],,,[$ac_includes_default
+ #include <sys/param.h>
+--
+2.4.0
+
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb
index 5a0dc954a3..013fe42ee3 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb
@@ -6,6 +6,7 @@ PR = "r3"
SRC_URI += " \
file://cfg \
+ file://0001-configure-fix-check-for-sys-sysmacros.h-under-glibc-.patch \
"
S = "${WORKDIR}/grub-${PV}"