aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-07-01 15:21:17 +0100
committerSaul Wold <sgw@linux.intel.com>2013-07-02 07:58:09 -0700
commit3ef5b19cbd7a90e11fc61223737b0b8e0e60b1a3 (patch)
tree3d39b25b0b9d371fb3824c56a6ea2d7cb1b0e37d
parent0edc61b9a38f93f06098b929662db6c3ce68670d (diff)
downloadopenembedded-core-contrib-3ef5b19cbd7a90e11fc61223737b0b8e0e60b1a3.tar.gz
lttng-modules: allow building without tracepoints enabled in kernel
Avoid a QA failure and instead produce a sensible warning message if no modules were built. Fixes [YOCTO #4791]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb
index 700c4c5760..0bbaa817ca 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.1.1.bb
@@ -22,3 +22,14 @@ export KERNEL_SRC="${STAGING_KERNEL_DIR}"
S = "${WORKDIR}/git"
+
+do_install_append() {
+ # Delete empty directories to avoid QA failures if no modules were built
+ find ${D}/lib -depth -type d -empty -exec rmdir {} \;
+}
+
+python do_package_prepend() {
+ if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
+ bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
+}
+