summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2019-05-14 20:21:40 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-05-20 15:56:01 +0000
commit50c2a0b96a0866e513328d95406ee0da44d93989 (patch)
tree4908d22df39cb6840852d6c2c350e7599fa0e6a4
parentd0900bd10f2023ec52dfe48895892b43a3a6a968 (diff)
downloadopenembedded-core-contrib-50c2a0b96a0866e513328d95406ee0da44d93989.tar.gz
pseudo-test
-rw-r--r--meta/recipes-devtools/pseudo/pseudo-test.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo-test.bb b/meta/recipes-devtools/pseudo/pseudo-test.bb
index 440a40057c..ec6380bddd 100644
--- a/meta/recipes-devtools/pseudo/pseudo-test.bb
+++ b/meta/recipes-devtools/pseudo/pseudo-test.bb
@@ -16,13 +16,17 @@ do_compile() {
ALL="all: "
for i in `seq -w 1 ${RULES}`; do
/bin/echo $i > ${S}/$i.txt
- /bin/echo -e "R$i:\n\t\$(QINSTALL) ${S}/$i.txt ${D}/$i.txt && mv ${D}/$i.txt ${D}/`expr $i + 1`.txt" >> Makefile;
+ /bin/echo -e "R$i:\n\t-\$(QINSTALL) ${S}/$i.txt ${D}/$i.txt && mv ${D}/$i.txt ${D}/`expr $i + 1`.txt" >> Makefile;
ALL="$ALL R$i"
done
/bin/echo ${ALL} >> Makefile
}
do_install() {
+ # create the files first, so qmake replaces them
+ for i in `seq -w 1 ${RULES}`; do
+ /bin/echo $i > ${D}/$i.txt
+ done
oe_runmake all
}