aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-03-27 13:22:32 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-28 17:39:00 +0000
commit42c0eba4fac6b8bd28b58ec04574d04b0ab0c457 (patch)
tree5367f3936c29a57528b36ef0dbce23adf21b96c2
parent821b1c03db3793609e3ae564358de10e23591604 (diff)
downloadopenembedded-core-contrib-42c0eba4fac6b8bd28b58ec04574d04b0ab0c457.tar.gz
linux-yocto/3.10: fix drm build failure
Andrea Adami reported the following build failure: .../drm/drm_mm.h:105:2: error: implicit declaration of function 'BUG_ON' [-Werror=implicit-function-declaration] | BUG_ON(!hole_node->hole_follows); | ^ | CC drivers/pci/setup-res.o | CC drivers/gpu/drm/i915/i915_drv.o | cc1: some warnings being treated as errors | make[6]: *** [drivers/gpu/drm/ttm/ttm_agp_backend.o] Error 1 | make[5]: *** [drivers/gpu/drm/ttm] Error 2 Cherry picking mainline commit 86e81f0e6 [drm/mm: include required headers in drm_mm.h] fixes the build problems. cc: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.10.bb14
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
index 9b0c5d3e23..fe6773a5ec 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
@@ -3,8 +3,8 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH = "standard/preempt-rt/base"
KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
-SRCREV_machine ?= "f121a3aa028df37b8050779adaa239d29aaa2edd"
-SRCREV_machine_qemuppc ?= "7172d3cbc73584e724b61ef5d13fc3519720f4c0"
+SRCREV_machine ?= "f4351616572c6ad5a8b71b1becf02c3e779b85b8"
+SRCREV_machine_qemuppc ?= "a6dfc85e99633d739068a03d2551e39847628551"
SRCREV_meta ?= "df3aa753c8826127fb5ad811d56d57168551d6e4"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
index baa82fd886..123f3070d9 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "3.10.34"
KMETA = "meta"
-SRCREV_machine ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c"
+SRCREV_machine ?= "c7739be126930006e3bfbdb2fb070a967abc5e09"
SRCREV_meta ?= "df3aa753c8826127fb5ad811d56d57168551d6e4"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.10.bb b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
index 56fbd07c21..49dd13db68 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
@@ -11,13 +11,13 @@ KBRANCH_qemux86 = "standard/common-pc/base"
KBRANCH_qemux86-64 = "standard/common-pc-64/base"
KBRANCH_qemumips64 = "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "e18e8c2c7cad913a25342f9f860eeeefce24b8aa"
-SRCREV_machine_qemumips ?= "6f191aaecfdbebda450cec4a1f30fb0d1a2ed889"
-SRCREV_machine_qemuppc ?= "ba2e16160c7f910de432511ca0008101a7b2263b"
-SRCREV_machine_qemux86 ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c"
-SRCREV_machine_qemux86-64 ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c"
-SRCREV_machine_qemumips64 ?= "e05f0378e9c21d689eed8aacb306d2c1a044e0d0"
-SRCREV_machine ?= "2ee37bfe732c73f7d39af55875ce8d30b282471c"
+SRCREV_machine_qemuarm ?= "0e99eabbe5b3bec853ace496f94612bc37800260"
+SRCREV_machine_qemumips ?= "b6b20f49e9a169a0672b7cc2d7b93d6652ca7873"
+SRCREV_machine_qemuppc ?= "d71b782615b802c78e1586494b94dd40531775c8"
+SRCREV_machine_qemux86 ?= "c7739be126930006e3bfbdb2fb070a967abc5e09"
+SRCREV_machine_qemux86-64 ?= "c7739be126930006e3bfbdb2fb070a967abc5e09"
+SRCREV_machine_qemumips64 ?= "88abb1eb327f4e3c711d19a228cb153fdd9b3506"
+SRCREV_machine ?= "c7739be126930006e3bfbdb2fb070a967abc5e09"
SRCREV_meta ?= "df3aa753c8826127fb5ad811d56d57168551d6e4"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"