summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2014-03-31 12:51:21 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-01 11:56:31 +0100
commitf7cd6b383f50ebc3000a9d9db8be719ab5b3c0bb (patch)
treee95047a1d457ffac4c240ebe2b9a9007c6a6e604
parent05a2fb19f722652c5d13be911b8ed45a264bbb40 (diff)
downloadopenembedded-core-contrib-f7cd6b383f50ebc3000a9d9db8be719ab5b3c0bb.tar.gz
openembedded-core-contrib-f7cd6b383f50ebc3000a9d9db8be719ab5b3c0bb.tar.bz2
openembedded-core-contrib-f7cd6b383f50ebc3000a9d9db8be719ab5b3c0bb.zip
core-image-lsb: enforce pam as a needed distro feature
core-image-lsb only gave a warning: "WARNING: Building libpam but 'pam' isn't in DISTRO_FEATURES, PAM won't work correctly" when the proper DISTRO was not set for it. default choice would be DISTRO = "poky-lsb", but not necessarily, depending on each custom distro. This fix will enforce the proper usage of pam as a distro feature for core-image-lsb by giving an error instead of just a warning. Fixes [YOCTO #6073] Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/images/core-image-lsb.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-extended/images/core-image-lsb.bb b/meta/recipes-extended/images/core-image-lsb.bb
index ed316a64e7..ab61c6e6df 100644
--- a/meta/recipes-extended/images/core-image-lsb.bb
+++ b/meta/recipes-extended/images/core-image-lsb.bb
@@ -9,4 +9,6 @@ IMAGE_INSTALL = "\
packagegroup-core-lsb \
"
-inherit core-image
+inherit core-image distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "pam"