aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-02-18 19:01:08 -0600
committerSaul Wold <sgw@linux.intel.com>2011-02-18 20:51:30 -0800
commit0a8f4f45b66ad5d51dea91a406a17555252dfe42 (patch)
tree8f470259f85c1d9fbd6d15448f85e599c8fa897e
parent9f0f7c43900e36610411b1d7901adf3d8f109f70 (diff)
downloadopenembedded-core-contrib-0a8f4f45b66ad5d51dea91a406a17555252dfe42.tar.gz
rpm: Increase the number of solvedb's allowed
Increase the number of allowed solvedb's to 20 from the original 5. We also add an additional error message to RPM incase the 20 is ever exceeded. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch29
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.0.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch b/meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch
new file mode 100644
index 0000000000..5c1819c367
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch
@@ -0,0 +1,29 @@
+Increase the maximum number of solver databases!
+
+Previously the max was set to 5, up this to 20... this should be more
+then enough for now.. also add an RPM_ERROR message in case we exceed the
+new maximum.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -urN rpm-5.4.0.orig/rpmio/rpmbag.c rpm-5.4.0/rpmio/rpmbag.c
+--- rpm-5.4.0.orig/rpmio/rpmbag.c 2010-10-17 21:43:55.000000000 -0500
++++ rpm-5.4.0/rpmio/rpmbag.c 2011-02-18 18:46:00.246892502 -0600
+@@ -16,7 +16,7 @@
+ /*@unchecked@*/
+ int _rpmbag_debug = 0;
+
+-static size_t _maxnsdbp = 5;
++static size_t _maxnsdbp = 20;
+
+ static void rpmbagFini(void * _bag)
+ /*@globals fileSystem @*/
+@@ -70,6 +70,8 @@
+ sdbp[i] = xcalloc(1, sizeof(*sdbp[i]));
+ sdbp[i]->dbmode = dbmode;
+ sdbp[i]->_db = _db;
++ } else if (bag && bag->sdbp && bag->nsdbp >= _maxnsdbp) {
++ rpmlog(RPMLOG_ERR, _("Attempted to open more then %d solver databases. Increase _maxnsdbp in rpmio/rpmbag.c\n"), _maxnsdbp);
+ }
+
+ return 0;
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.0.bb b/meta/recipes-devtools/rpm/rpm_5.4.0.bb
index 45dd4e1ee2..ac9df6fa82 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.0.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.0.bb
@@ -43,7 +43,7 @@ LICENSE = "LGPL 2.1"
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS = "bzip2 zlib python perl db openssl elfutils expat libpcre attr acl popt"
-PR = "r12"
+PR = "r13"
# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
# in order to extract the distribution SRPM into a format we can extract...
@@ -55,6 +55,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.0-0.20101229.src.rpm;ex
file://rpm-platform.patch \
file://rpm-showrc.patch \
file://rpm-nofsync.patch \
+ file://rpm-solvedb.patch \
"
# file://hdraddorappend.patch \