aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingdong Lu <jingdong.lu@windriver.com>2011-02-23 16:29:44 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2011-03-01 11:46:47 +0000
commit94908bd435607a6549b003ef501e8a7995cfffae (patch)
tree8617a7bfeb0299269584cff8a93e35a585720f74
parentd5c7292aba8b8ccb8277675888ea98604873e3a7 (diff)
downloadopenembedded-core-contrib-94908bd435607a6549b003ef501e8a7995cfffae.tar.gz
task-poky-lsb: add necessary packages name
In order to install and run LSB test cases we should add some necessary packages name into task-poky-lsb for lsb image. [sgw: modified the perl and python lists to use the core -modules, removed mesa-dri] Signed-off-by: Jingdong Lu <jingdong.lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-extended/tasks/task-poky-lsb.bb62
1 files changed, 61 insertions, 1 deletions
diff --git a/meta/recipes-extended/tasks/task-poky-lsb.bb b/meta/recipes-extended/tasks/task-poky-lsb.bb
index 9d308e77c6..5120764288 100644
--- a/meta/recipes-extended/tasks/task-poky-lsb.bb
+++ b/meta/recipes-extended/tasks/task-poky-lsb.bb
@@ -3,7 +3,7 @@
#
DESCRIPTION = "Create Small Image Tasks"
-PR = "r2"
+PR = "r3"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${POKYBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
@@ -28,8 +28,14 @@ PACKAGES = "\
task-poky-tcl \
task-poky-tcl-dbg \
task-poky-tcl-dev \
+ task-poky-lsb-perl-add \
+ task-poky-lsb-python-add \
+ task-poky-lsb-graphic-add \
+ task-poky-lsb-runtime-add \
+ task-poky-lsb-command-add \
"
+
ALLOW_EMPTY = "1"
RDEPENDS_task-poky-lsb = "\
@@ -39,6 +45,11 @@ RDEPENDS_task-poky-lsb = "\
task-poky-perl \
task-poky-python \
task-poky-tcl \
+ task-poky-lsb-perl-add \
+ task-poky-lsb-python-add \
+ task-poky-lsb-graphic-add \
+ task-poky-lsb-runtime-add \
+ task-poky-lsb-command-add \
"
#
@@ -111,3 +122,52 @@ RDEPENDS_task-poky-misc = "\
usbutils \
zlib \
"
+
+RDEPENDS_task-poky-lsb-command-add = "\
+ localedef \
+ fontconfig-utils \
+ mailx \
+ msmtp \
+"
+# cups
+
+RDEPENDS_task-poky-lsb-perl-add = "\
+ perl-modules \
+ perl-dev \
+ perl-misc \
+ perl-pod \
+"
+
+RDEPENDS_task-poky-lsb-python-add = "\
+ python-modules \
+"
+
+RDEPENDS_task-poky-lsb-graphic-add = "\
+ libqtcore4 \
+ libqtgui4 \
+ libqtsql4 \
+ libqtsvg4 \
+ libqtxml4 \
+ libqtnetwork4 \
+ libqtopengl4 \
+ libxt \
+ libxxf86vm \
+ libdrm \
+ libglu \
+ libxi \
+ libxtst \
+ qt4-plugin-sqldriver-sqlite \
+"
+
+# mesa-dri
+
+RDEPENDS_task-poky-lsb-runtime-add = "\
+ ldd \
+ pam-plugin-wheel \
+ e2fsprogs-mke2fs \
+ eglibc-localedata-posix \
+ mkfontdir \
+ liburi-perl \
+ libxml-parser-perl \
+ libxml-perl \
+"