aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-09 08:56:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:52 +0000
commita1986acf66381dee18f5c8deae7cf52490d0f58a (patch)
treeae18b450f661891e68bbfe2253a1ee52cac0ce79
parent0b1b091bcfee268773002e8f015ead77c9de953a (diff)
downloadopenembedded-core-contrib-a1986acf66381dee18f5c8deae7cf52490d0f58a.tar.gz
systemd: Skip parsing on musl based targets
systemd on musl doesn't yet work even though we have patches to make it compile it fails to run, therefore lets skip building it for now Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-core/systemd/systemd_228.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_228.bb b/meta/recipes-core/systemd/systemd_228.bb
index aa2e846b69..0e1bd8b7f1 100644
--- a/meta/recipes-core/systemd/systemd_228.bb
+++ b/meta/recipes-core/systemd/systemd_228.bb
@@ -443,4 +443,8 @@ pkg_prerm_udev-hwdb () {
python () {
if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
+
+ import re
+ if re.match('.*musl*', d.getVar('TARGET_OS', True)) != None:
+ raise bb.parse.SkipPackage("Not _yet_ supported on musl based targets")
}