summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlistair Francis <alistair.francis@wdc.com>2020-01-30 15:04:23 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-02 16:56:26 +0000
commit472507b8c446dcfe3cb08deecfbca4e5928ca504 (patch)
tree82baa901f6435990d77028da6412fe92747d4226
parent575fca95307dafb3f7d80f9bf0e63605a9328b59 (diff)
downloadopenembedded-core-contrib-472507b8c446dcfe3cb08deecfbca4e5928ca504.tar.gz
opensbi: Remove dependency on FDT
U-Boot no longer requires OpenSBI to include a FDT for the HiFive Unleashed, so remove the support from OpenSBI. Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/opensbi/opensbi-payloads.inc20
-rw-r--r--meta/recipes-bsp/opensbi/opensbi_0.5.bb4
2 files changed, 2 insertions, 22 deletions
diff --git a/meta/recipes-bsp/opensbi/opensbi-payloads.inc b/meta/recipes-bsp/opensbi/opensbi-payloads.inc
index b9714a7acb..2e32943245 100644
--- a/meta/recipes-bsp/opensbi/opensbi-payloads.inc
+++ b/meta/recipes-bsp/opensbi/opensbi-payloads.inc
@@ -7,18 +7,8 @@ def riscv_get_extra_oemake_image(d):
return "FW_PAYLOAD_PATH=" + deploy_dir + "/" + sbi_payload
-def riscv_get_extra_oemake_fdt(d):
- sbi_fdt_payload = d.getVar('RISCV_SBI_FDT')
- deploy_dir = d.getVar('DEPLOY_DIR_IMAGE')
-
- if sbi_fdt_payload is None:
- return ""
-
- return "FW_PAYLOAD_FDT_PATH=" + deploy_dir + "/" + sbi_fdt_payload
-
def riscv_get_do_compile_depends(d):
sbi_payload = d.getVar('RISCV_SBI_PAYLOAD')
- sbi_fdt_payload = d.getVar('RISCV_SBI_FDT')
if sbi_payload is None:
return ""
@@ -26,14 +16,6 @@ def riscv_get_do_compile_depends(d):
if 'linux' in sbi_payload or 'Image' in sbi_payload:
return "virtual/kernel:do_deploy"
if 'u-boot.bin' in sbi_payload:
- # If we want U-Boot and a FDT then we need to depend on U-Boot and
- # the kernel
- if sbi_fdt_payload is not None:
- return "virtual/bootloader:do_deploy virtual/kernel:do_deploy"
- else:
- return "virtual/bootloader:do_deploy"
- # If we want a custom FDT then we need to depend on the kernel
- if sbi_fdt_payload is not None:
- return "virtual/kernel:do_deploy"
+ return "virtual/bootloader:do_deploy"
return ""
diff --git a/meta/recipes-bsp/opensbi/opensbi_0.5.bb b/meta/recipes-bsp/opensbi/opensbi_0.5.bb
index 6a9026254c..71d64fa324 100644
--- a/meta/recipes-bsp/opensbi/opensbi_0.5.bb
+++ b/meta/recipes-bsp/opensbi/opensbi_0.5.bb
@@ -2,7 +2,6 @@ SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5"
-DEPENDS += "dtc-native"
require opensbi-payloads.inc
@@ -21,7 +20,7 @@ SRC_URI[sha256sum] = "07f18b73abf3b85aabe5bead19a923716c100d30eb58033459f39c3a22
EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D}"
# If RISCV_SBI_PAYLOAD is set then include it as a payload
-EXTRA_OEMAKE_append = " ${@riscv_get_extra_oemake_image(d)} ${@riscv_get_extra_oemake_fdt(d)}"
+EXTRA_OEMAKE_append = " ${@riscv_get_extra_oemake_image(d)}"
# Required if specifying a custom payload
do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
@@ -47,7 +46,6 @@ FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
-
COMPATIBLE_HOST = "(riscv64|riscv32).*"
INHIBIT_PACKAGE_STRIP = "1"