aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2017-01-17 00:33:02 +0100
committerAndreas Oberritter <obi@opendreambox.org>2019-04-08 13:49:57 +0200
commit92c7a0885627c5b81f2d9cb702a5b0e20803febe (patch)
tree242613e6c7cc88c2dd8c6ae92f1629c6c59d1c02
parentbfd40d438f44f3147e3c5c66ee9aa938d3fd0916 (diff)
downloadopenembedded-core-contrib-92c7a0885627c5b81f2d9cb702a5b0e20803febe.tar.gz
python3-pycairo: use waf.bbclass
Fixes compilation with PARALLEL_MAKE = "-j N -l N". Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-devtools/python/python3-pycairo_1.10.0.bb20
1 files changed, 2 insertions, 18 deletions
diff --git a/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb b/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
index f9031b3bca..4cb2fe87c9 100644
--- a/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
+++ b/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
@@ -17,24 +17,8 @@ SRC_URI[sha256sum] = "9aa4078e7eb5be583aeabbe8d87172797717f95e8c4338f0d4a17b683a
S = "${WORKDIR}/pycairo-${PV}"
-inherit distutils3 pkgconfig
+inherit distutils3 pkgconfig waf
BBCLASSEXTEND = "native"
-do_configure() {
- PYTHON=${PYTHON} ./waf configure --prefix=${D}${prefix} --libdir=${D}${libdir}
-}
-
-do_compile() {
- ./waf build ${PARALLEL_MAKE}
-}
-
-do_install() {
- ./waf install
- sed \
- -e 's:@prefix@:${prefix}:' \
- -e 's:@VERSION@:${PV}:' \
- -e 's:@includedir@:${includedir}:' \
- py3cairo.pc.in > py3cairo.pc
- install -m 0644 py3cairo.pc ${D}${libdir}/pkgconfig/
-}
+export PYTHON