aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2019-03-11 22:13:33 +0100
committerAndreas Oberritter <obi@opendreambox.org>2019-04-08 13:49:57 +0200
commite16f90aac4126138f6c10cdb39fd34a021d493be (patch)
tree00439e575dd5f053d3ae465a59aba5d1c1bcba8a
parent0596ae31af50902f483f32196c7eaa934b2eb496 (diff)
downloadopenembedded-core-contrib-e16f90aac4126138f6c10cdb39fd34a021d493be.tar.gz
dpkg: Don't abort if unused tools are missing, e.g. ldconfig and start-stop-daemon
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-devtools/dpkg/dpkg/0001-help-make-sure-dpkg-continues-to-work-if-unused-tool.patch36
-rw-r--r--meta/recipes-devtools/dpkg/dpkg_1.18.10.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dpkg/dpkg/0001-help-make-sure-dpkg-continues-to-work-if-unused-tool.patch b/meta/recipes-devtools/dpkg/dpkg/0001-help-make-sure-dpkg-continues-to-work-if-unused-tool.patch
new file mode 100644
index 0000000000..a498fe40d1
--- /dev/null
+++ b/meta/recipes-devtools/dpkg/dpkg/0001-help-make-sure-dpkg-continues-to-work-if-unused-tool.patch
@@ -0,0 +1,36 @@
+From 1b082e96c5a6f381d6e55cd4e2924a110d7058fc Mon Sep 17 00:00:00 2001
+From: Andreas Oberritter <obi@opendreambox.org>
+Date: Thu, 7 Mar 2019 13:42:25 +0100
+Subject: [PATCH] help: make sure dpkg continues to work if unused tools are
+ not in PATH
+
+Dpkg looks for some tools it doesn't use. They might get used by scripts,
+but it's perfectly valid to build a rootfs not containing ldconfig or
+start-stop-daemon, even if start-stop-daemon was built.
+
+Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
+---
+ src/help.c | 10 ----------
+ 1 file changed, 10 deletions(-)
+
+diff --git a/src/help.c b/src/help.c
+index aa9b11c38..770aaf5bd 100644
+--- a/src/help.c
++++ b/src/help.c
+@@ -121,16 +121,6 @@ void checkpath(void) {
+ TAR,
+ DIFF,
+ BACKEND,
+- /* Mac OS X uses dyld (Mach-O) instead of ld.so (ELF), and does not have
+- * an ldconfig. */
+-#if defined(__APPLE__) && defined(__MACH__)
+- "update_dyld_shared_cache",
+-#else
+- "ldconfig",
+-#endif
+-#if BUILD_START_STOP_DAEMON
+- "start-stop-daemon",
+-#endif
+ NULL
+ };
+
diff --git a/meta/recipes-devtools/dpkg/dpkg_1.18.10.bb b/meta/recipes-devtools/dpkg/dpkg_1.18.10.bb
index 09f6b5a804..b6c9398d62 100644
--- a/meta/recipes-devtools/dpkg/dpkg_1.18.10.bb
+++ b/meta/recipes-devtools/dpkg/dpkg_1.18.10.bb
@@ -14,6 +14,7 @@ SRC_URI = "http://snapshot.debian.org/archive/debian/20160731T221931Z/pool/main/
file://0006-add-musleabi-to-known-target-tripets.patch \
file://0007-dpkg-deb-build.c-Remove-usage-of-clamp-mtime-in-tar.patch \
file://0007-update-alternatives-disable-logging.patch \
+ file://0001-help-make-sure-dpkg-continues-to-work-if-unused-tool.patch \
"
SRC_URI_append_class-native = " file://glibc2.5-sync_file_range.patch "