aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2017-04-12 14:14:08 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-25 23:35:51 +0100
commit399c0fdbaacf660750f874e5190dd9955ad9bb58 (patch)
tree47038494080961bdc86f32b6f3b2eb80b94b6c0f
parent1143181577051ccd6de234fd79542bff24045280 (diff)
downloadopenembedded-core-contrib-399c0fdbaacf660750f874e5190dd9955ad9bb58.tar.gz
kmscube: add recipe
This is a demo application that draws a three-dimensional spinning cube using EGL on top of KMS, via Mesa's GBM library. A rough counterpart to glxgears, it is a useful tool for BSP makers to try the 3D rendering functionality based on EGL and OpenGL ES in a KMS environment, without having to set up Wayland or X11. It is also interesting for Yocto-based projects that do not need any windowing environment and instead render their visual output fullscreen to KMS directly, since they can use it as a reference. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/kmscube/kmscube_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-graphics/kmscube/kmscube_git.bb b/meta/recipes-graphics/kmscube/kmscube_git.bb
new file mode 100644
index 0000000000..518c98e123
--- /dev/null
+++ b/meta/recipes-graphics/kmscube/kmscube_git.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Demo application to showcase 3D graphics using kms and gbm"
+HOMEPAGE = "https://cgit.freedesktop.org/mesa/kmscube/"
+LICENSE = "MIT"
+SECTION = "graphics"
+DEPENDS = "virtual/libgles2 virtual/egl libdrm gstreamer1.0 gstreamer1.0-plugins-base"
+
+LIC_FILES_CHKSUM = "file://kmscube.c;beginline=1;endline=23;md5=8b309d4ee67b7315ff7381270dd631fb"
+
+SRCREV = "e56980c28766ffb0bf8edee96b529a5b47f97137"
+SRC_URI = "git://anongit.freedesktop.org/mesa/kmscube;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig