summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Le Magourou <pierre.lemagourou@softbankrobotics.com>2019-07-08 10:59:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-10 09:55:45 +0100
commitc807c2a6409e122599196cd914a638b00121cab6 (patch)
tree3ca7db56f17c5714d792b8193ed735a8756a231e
parentfedc57a41a15bca1d96d14e25e2df0bb1eca904d (diff)
downloadopenembedded-core-contrib-c807c2a6409e122599196cd914a638b00121cab6.tar.gz
cve-update-db-native: Skip recipe when cve-check class is not loaded.
Signed-off-by: Pierre Le Magourou <pierre.lemagourou@softbankrobotics.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index d658c7bfea..e16c41a72f 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -13,6 +13,11 @@ deltask do_compile
deltask do_install
deltask do_populate_sysroot
+python () {
+ if not d.getVar("CVE_CHECK_DB_FILE"):
+ raise bb.parse.SkipRecipe("Skip recipe when cve-check class is not loaded.")
+}
+
python do_populate_cve_db() {
"""
Update NVD database with json data feed