aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOoi Cinly <cinly.ooi@intel.com>2017-08-16 09:17:50 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-18 12:35:58 +0100
commit04db02138e363898e040e33557f1296e8a43c3fd (patch)
tree40ae36d30aba4aa85441fbfa73f99ebacf2a37b7
parenta945141062ac3d0736558be428f60af405b53a94 (diff)
downloadopenembedded-core-contrib-04db02138e363898e040e33557f1296e8a43c3fd.tar.gz
libtool: remove /absolute/path/to/host references
Removed all instances of -fdebug-prefix-map in LTCFLAGS declaration because they contain references to host system and are not needed. /absolute/path/to/host/dd was replaced with 'dd' in lt_truncate_bin declaration. Please take note that the location of regex is important for DEBUG_PREFIX_MAP. Removal of DEBUG_PREFIX_MAP has to be done before other regex command modify its option value. Both are modified because they affect binary reproducibility. [YOCTO #11656] Signed-off-by: Ooi Cinly <cinly.ooi@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/libtool/libtool_2.4.6.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool_2.4.6.bb b/meta/recipes-devtools/libtool/libtool_2.4.6.bb
index 06abb05584..b02620b4b4 100644
--- a/meta/recipes-devtools/libtool/libtool_2.4.6.bb
+++ b/meta/recipes-devtools/libtool/libtool_2.4.6.bb
@@ -15,6 +15,7 @@ ACLOCALEXTRAPATH_class-target = ""
do_install_append () {
sed -e 's@--sysroot=${STAGING_DIR_HOST}@@g' \
+ -e "s@${DEBUG_PREFIX_MAP}@@g" \
-e 's@${STAGING_DIR_HOST}@@g' \
-e 's@${STAGING_DIR_NATIVE}@@g' \
-e 's@^\(sys_lib_search_path_spec="\).*@\1${libdir} ${base_libdir}"@' \
@@ -22,5 +23,6 @@ do_install_append () {
-e 's@^\(compiler_lib_search_path="\).*@\1${libdir} ${base_libdir}"@' \
-e 's@^\(predep_objects="\).*@\1"@' \
-e 's@^\(postdep_objects="\).*@\1"@' \
+ -e "s@${HOSTTOOLS_DIR}/@@g" \
-i ${D}${bindir}/libtool
}