aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-04-04 11:09:29 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-05 23:22:06 +0100
commit95d6910bb5d9331adb7a693fcb4f7b1271c68cc6 (patch)
tree4ef14bcefe26eeb112429f4b066be935613e348e
parent19be2237798f51c01c1c21a68382d114a2f6ead2 (diff)
downloadopenembedded-core-contrib-95d6910bb5d9331adb7a693fcb4f7b1271c68cc6.tar.gz
net-tools: Fix build with USE_NLS="no"
The configuration change was already done for -native but we really want it when USE_NLS is set. Fixes [YOCTO #11285]. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-26.bb14
1 files changed, 4 insertions, 10 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
index 115b3987c3..45d7bf4524 100644
--- a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
@@ -70,21 +70,15 @@ python do_patch() {
bb.build.exec_func('patch_do_patch', d)
}
-# i18n only enabled for the target, doesn't build for native
-# and isn't needed there.
-disable_i18n() {
- sed -i -e 's/^I18N=1/# I18N=1/' ${S}/config.make
-}
-disable_i18n_class-target () {
- :
-}
-
do_configure() {
# net-tools has its own config mechanism requiring "make config"
# we pre-generate desired options and copy to source directory instead
cp ${WORKDIR}/net-tools-config.h ${S}/config.h
cp ${WORKDIR}/net-tools-config.make ${S}/config.make
- disable_i18n
+
+ if [ "${USE_NLS}" = "no" ]; then
+ sed -i -e 's/^I18N=1/# I18N=1/' ${S}/config.make
+ fi
}
do_compile() {