aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-04-13 02:57:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-13 23:57:38 +0100
commit081974e75cc0cfa0a1a1bb01cd9f9cbc585b7692 (patch)
tree1ca873ff23fc7534f671fcc4d44ae44ed37471a3
parentbf867019c33c34dc997e10a3bdba4aeee81f559a (diff)
downloadopenembedded-core-contrib-081974e75cc0cfa0a1a1bb01cd9f9cbc585b7692.tar.gz
grep: do_configure: fix "Argument list too long"
Fixed when len(TMPDIR) = 410: aclocal: error: cannot open echo 'm4_define [snip]' configure.ac |: Argument list too long' This is becuase it has a lot of m4 files, use relative path for them can fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/grep/grep_3.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_3.0.bb b/meta/recipes-extended/grep/grep_3.0.bb
index 6146ef00f3..b2940d5429 100644
--- a/meta/recipes-extended/grep/grep_3.0.bb
+++ b/meta/recipes-extended/grep/grep_3.0.bb
@@ -16,6 +16,9 @@ inherit autotools gettext texinfo pkgconfig
EXTRA_OECONF = "--disable-perl-regexp"
+# Fix "Argument list too long" error when len(TMPDIR) = 410
+acpaths = "-I ./m4"
+
do_configure_prepend () {
rm -f ${S}/m4/init.m4
}