summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-06-16 17:46:32 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-17 11:09:28 +0100
commit41fac86156bfddfa604a604c6dc0d98b886a7586 (patch)
tree58466858a60e15f554f574b0ecb241e74c072566
parent8a7c7794870815030239e90b03e37ed302b7e885 (diff)
downloadopenembedded-core-contrib-41fac86156bfddfa604a604c6dc0d98b886a7586.tar.gz
perl: use relative paths in the perl wrapper
Use SDKPATHNATIVE so that the perl wrapper for the nativesdk can be created using relative paths and without dependency to the environment variables. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.30.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.30.2.bb b/meta/recipes-devtools/perl/perl_5.30.2.bb
index 804520d885..88a1c9665a 100644
--- a/meta/recipes-devtools/perl/perl_5.30.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.30.2.bb
@@ -156,7 +156,7 @@ do_install_append_class-nativesdk() {
ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl
create_wrapper ${D}${bindir}/perl \
- PERL5LIB='$PERL5LIB:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/site_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/vendor_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl5/${PV}'
+ PERL5LIB='$PERL5LIB:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/site_perl/${PV}:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/vendor_perl/${PV}:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/${PV}'
}
do_install_append_class-native () {