aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-03-08 15:17:14 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-10 10:15:46 +0000
commit09266d6c91acd8ba4df6e8242aa44d9ba41e9cee (patch)
tree41535fde0a13207e1795668ef897c1d3fdee47ee
parent2b15451e3f1b9fb9a7f44317f3f9cd22d8712ff5 (diff)
downloadopenembedded-core-contrib-09266d6c91acd8ba4df6e8242aa44d9ba41e9cee.tar.gz
meta: do not append to BBCLASSEXTEND
Replace some "+=/=+" with "=" when setting BBCLASSEXTEND, they are redundant and inconsistent with the same setting in other recipes. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/build-compare/build-compare_git.bb2
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.6.24.bb2
-rw-r--r--meta/recipes-extended/lzip/lzip_1.18.bb2
-rw-r--r--meta/recipes-extended/wget/wget.inc2
-rw-r--r--meta/recipes-support/ca-certificates/ca-certificates_20161130.bb2
-rw-r--r--meta/recipes-support/lz4/lz4.bb2
-rw-r--r--meta/recipes-support/lzop/lzop_1.03.bb2
7 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-devtools/build-compare/build-compare_git.bb b/meta/recipes-devtools/build-compare/build-compare_git.bb
index e432143d91..eb12e40eeb 100644
--- a/meta/recipes-devtools/build-compare/build-compare_git.bb
+++ b/meta/recipes-devtools/build-compare/build-compare_git.bb
@@ -22,7 +22,7 @@ PV = "git+${SRCPV}"
S = "${WORKDIR}/git"
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
do_install() {
install -d ${D}/${bindir}
diff --git a/meta/recipes-extended/libsolv/libsolv_0.6.24.bb b/meta/recipes-extended/libsolv/libsolv_0.6.24.bb
index 6de38b5915..73db5ed2cc 100644
--- a/meta/recipes-extended/libsolv/libsolv_0.6.24.bb
+++ b/meta/recipes-extended/libsolv/libsolv_0.6.24.bb
@@ -27,4 +27,4 @@ FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibSolv.cmake"
FILES_${PN}-tools = "${bindir}/*"
FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
-BBCLASSEXTEND =+ "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/lzip/lzip_1.18.bb b/meta/recipes-extended/lzip/lzip_1.18.bb
index 30c7dd5a6d..c1dc8ced4a 100644
--- a/meta/recipes-extended/lzip/lzip_1.18.bb
+++ b/meta/recipes-extended/lzip/lzip_1.18.bb
@@ -38,4 +38,4 @@ do_install () {
fi
}
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/wget/wget.inc b/meta/recipes-extended/wget/wget.inc
index 9eb051ff6a..1299edb720 100644
--- a/meta/recipes-extended/wget/wget.inc
+++ b/meta/recipes-extended/wget/wget.inc
@@ -16,7 +16,7 @@ ALTERNATIVE_PRIORITY = "100"
RRECOMMENDS_${PN} += "ca-certificates"
-BBCLASSEXTEND += "nativesdk"
+BBCLASSEXTEND = "nativesdk"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[libuuid] = "--with-libuuid, --without-libuuid,util-linux"
diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20161130.bb b/meta/recipes-support/ca-certificates/ca-certificates_20161130.bb
index e47bad11b7..42088b9899 100644
--- a/meta/recipes-support/ca-certificates/ca-certificates_20161130.bb
+++ b/meta/recipes-support/ca-certificates/ca-certificates_20161130.bb
@@ -80,4 +80,4 @@ do_install_append_class-native () {
RDEPENDS_${PN} += "openssl"
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/lz4/lz4.bb b/meta/recipes-support/lz4/lz4.bb
index 18e56d04c6..03c5a7ab39 100644
--- a/meta/recipes-support/lz4/lz4.bb
+++ b/meta/recipes-support/lz4/lz4.bb
@@ -18,4 +18,4 @@ do_install() {
oe_runmake install
}
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/lzop/lzop_1.03.bb b/meta/recipes-support/lzop/lzop_1.03.bb
index 649e7243ee..6f09002f55 100644
--- a/meta/recipes-support/lzop/lzop_1.03.bb
+++ b/meta/recipes-support/lzop/lzop_1.03.bb
@@ -26,4 +26,4 @@ do_configure_prepend () {
install -Dm 0644 ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
}
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"