aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2017-03-08 17:24:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-10 14:45:43 +0000
commit6486dd71c6c9977e5d67fd803d1bd85001654b5a (patch)
treef4b6d8d90657863eacdf97371c75a915fbfdb1c8
parent96ed437d57316153453bb5e170a4fd4f3a95883d (diff)
downloadopenembedded-core-contrib-6486dd71c6c9977e5d67fd803d1bd85001654b5a.tar.gz
chkconfig-alternatives-native: fix obey_variables
This postfunc assumes it's run from S, whereas that seems not to always be the case in practice. Explicitly define the full path of the file we wish to sed. Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb b/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
index c0f7f1674f..87fa8eb605 100644
--- a/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
+++ b/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
@@ -21,7 +21,7 @@ inherit native
# into the sysroot, as we may use them to construct the rootfs. As such, we
# only adjust the paths to match the metadata for the target, not native.
obey_variables () {
- sed -i 's,ALTERNATIVES_ROOT,OPKG_OFFLINE_ROOT,' alternatives.c
+ sed -i 's,ALTERNATIVES_ROOT,OPKG_OFFLINE_ROOT,' ${S}/alternatives.c
}
do_compile () {