aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-12-02 11:41:57 +1300
committerPaul Eggleton <paul.eggleton@linux.intel.com>2016-05-09 16:18:56 +1200
commit325e4f058e886c69ab0da5ca7f226bf3ffb5784c (patch)
tree02e2955e6c0d76abcbabc892f5c8ad0fb225877c
parent85ffd927c7834f4111ae1740b8aad5a9c444b7aa (diff)
downloadopenembedded-core-contrib-325e4f058e886c69ab0da5ca7f226bf3ffb5784c.tar.gz
eudev: check for required kernel config options
Use the list in the udev 220 README (since that is apparently what this is equivalent to; unfortunately eudev doesn't provide the same document) to set required Linux kernel config options, with the exception of CONFIG_HOTPLUG which is always on for 3.11 and later kernels. Fixes [YOCTO #5574]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--meta/recipes-core/udev/eudev_3.1.5.bb22
1 files changed, 21 insertions, 1 deletions
diff --git a/meta/recipes-core/udev/eudev_3.1.5.bb b/meta/recipes-core/udev/eudev_3.1.5.bb
index e42630f5cf..41d72f626a 100644
--- a/meta/recipes-core/udev/eudev_3.1.5.bb
+++ b/meta/recipes-core/udev/eudev_3.1.5.bb
@@ -23,7 +23,27 @@ UPSTREAM_CHECK_URI = "https://github.com/gentoo/eudev/releases"
SRC_URI[md5sum] = "e130f892d8744e292cb855db79935f68"
SRC_URI[sha256sum] = "ce9d5fa91e3a42c7eb95512ca0fa2a631e89833053066bb6cdf42046b2a88553"
-inherit autotools update-rc.d qemu
+inherit autotools update-rc.d qemu kernel-check
+
+# All the required options from the udev README
+# (except for CONFIG_HOTPLUG which is always on in
+# 3.11 and later kernels.)
+REQUIRED_KERNEL_OPTIONS = "\
+ CONFIG_DEVTMPFS \
+ CONFIG_CGROUPS \
+ CONFIG_INOTIFY_USER \
+ CONFIG_SIGNALFD \
+ CONFIG_TIMERFD \
+ CONFIG_EPOLL \
+ CONFIG_NET \
+ CONFIG_SYSFS \
+ CONFIG_SYSFS_DEPRECATED=n \
+ CONFIG_SYSFS_DEPRECATED_V2=n \
+ CONFIG_PROC_FS \
+ CONFIG_FHANDLE \
+ CONFIG_UEVENT_HELPER_PATH='' \
+ CONFIG_FW_LOADER_USER_HELPER=n \
+ "
EXTRA_OECONF = " \
--sbindir=${base_sbindir} \