aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-06-14 12:33:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-14 14:45:01 +0100
commit0c6e4a14ba8d9d9701ec16ffe46d618f41633571 (patch)
tree30cce70dba01e7e774b9e0baaa6fbec3432a08a2
parent987363c3c720b3764f4d64976d7455f6b0bae99c (diff)
downloadopenembedded-core-contrib-0c6e4a14ba8d9d9701ec16ffe46d618f41633571.tar.gz
Revert "bitbake.conf: DISTRO_FEATURES as overrides"
This reverts commit 3b3ae91a22d6f685e804df4f32cdeebe1bd6bd88. It turned out that the code which expands DISTRO_FEATURES early during base config parsing can fail because some entries in DISTRO_FEATURES might call Python functions like base_conditional() from base.bbclass which aren't defined yet. A different solution will be needed. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/bitbake.conf17
1 files changed, 1 insertions, 16 deletions
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index 5d5ddec499..80baec8d40 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -713,28 +713,13 @@ DISTRO_NAME ??= "OpenEmbedded"
#
# This works for functions as well, they are really just environment variables.
# Default OVERRIDES to make compilation fail fast in case of build system misconfiguration.
-OVERRIDES = "${TARGET_OS}:${TRANSLATED_TARGET_ARCH}:build-${BUILD_OS}:pn-${PN}:${MACHINEOVERRIDES}:${DISTROOVERRIDES}${DISTROFEATURESOVERRIDES}:${CLASSOVERRIDE}:forcevariable"
+OVERRIDES = "${TARGET_OS}:${TRANSLATED_TARGET_ARCH}:build-${BUILD_OS}:pn-${PN}:${MACHINEOVERRIDES}:${DISTROOVERRIDES}:${CLASSOVERRIDE}:forcevariable"
CLASSOVERRIDE ?= "class-target"
DISTROOVERRIDES ?= "${@d.getVar('DISTRO') or ''}"
MACHINEOVERRIDES ?= "${MACHINE}"
FILESOVERRIDES = "${TRANSLATED_TARGET_ARCH}:${MACHINEOVERRIDES}:${DISTROOVERRIDES}"
-# Turns certain DISTRO_FEATURES into overrides of the same name
-# or (optionally) some other name. Ensures that these special
-# distro features remain set also for native and nativesdk
-# recipes, so that these overrides can also be used there.
-#
-# Beware that this part of OVERRIDES changes during parsing, so usage
-# of these overrides should be limited to .bb and .bbappend files,
-# because then DISTRO_FEATURES is final.
-DISTRO_FEATURES_OVERRIDES ??= ""
-DISTRO_FEATURES_OVERRIDES[doc] = "A space-separated list of <feature> entries. \
-Each entry is added to OVERRIDES as df-<feature> if <feature> is in DISTRO_FEATURES."
-DISTRO_FEATURES_FILTER_NATIVE_append = " ${DISTRO_FEATURES_OVERRIDES}"
-DISTRO_FEATURES_FILTER_NATIVESDK_append = " ${DISTRO_FEATURES_OVERRIDES}"
-DISTROFEATURESOVERRIDES = "${@ ''.join([':df-' + x for x in (set(d.getVar('DISTRO_FEATURES_OVERRIDES').split()) & set((d.getVar('DISTRO_FEATURES') or '').split()))]) }"
-
##################################################################
# Include the rest of the config files.
##################################################################