aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-04-24 15:43:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-10 12:21:34 +0100
commit54a2549802a911cad2475a6aa379315a834419d8 (patch)
treeb1c9c4073780da8c0a1a6581c52eb9ef438a704a
parent270cd793fa2777bf15930ee4873c7b44a22ad005 (diff)
downloadopenembedded-core-contrib-54a2549802a911cad2475a6aa379315a834419d8.tar.gz
python3: add python3 metapackage
Many new users add "python3" to their image using IMAGE_INSTALL and are then surprised that they can't import any of the standard library. This is because we split up the standard library into a number of packages, and python3-core (the interpreter and essential modules only) RPROVIDES 'python3'. Solve this by moving the RPROVIDES of 'python3' to python3-modules, so that the entire Python standard library is installed. [ YOCTO #11182 ] Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3_3.5.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.2.bb b/meta/recipes-devtools/python/python3_3.5.2.bb
index 2ff7c9e278..7f2bc7186f 100644
--- a/meta/recipes-devtools/python/python3_3.5.2.bb
+++ b/meta/recipes-devtools/python/python3_3.5.2.bb
@@ -193,7 +193,7 @@ py_package_preprocess () {
require python-${PYTHON_MAJMIN}-manifest.inc
# manual dependency additions
-RPROVIDES_${PN}-core = "${PN}"
+RPROVIDES_${PN}-modules = "${PN}"
RRECOMMENDS_${PN}-core = "${PN}-readline"
RRECOMMENDS_${PN}-crypt = "openssl"
RRECOMMENDS_${PN}-crypt_class-nativesdk = "nativesdk-openssl"